Can't add Python SDKs

Answered

Using IntelliJ Ultimate 2018.1 with updated Python plugin.
Didn't import any Python related stuff from previous version.

There's no possibility to add a Python SDK:


Clicking on the icon for 'Project Structure', then choosing 'Platform Settings -> SDKs', the clicking the 'plus sign', then clicking the popping-up 'Add...' box (there's no 'Add local...' or anything else)... nothing happens.

IDE log is here: https://pastebin.com/bCnWFgg2 

Any ideas?

24 comments
Comment actions Permalink

Please enable SSH Remote Run and Remote Hosts Access plugins, restart IntelliJ IDEA and check the problem again. Does the issue remain?

5
Comment actions Permalink

Hi,

 

I am having the same problem on CentOS  7.2.1511. I have both the SSH Remote Run and Remote Hosts Access plugins installed. Trying to add a Python SDK does nothing -- no errors, no window pops up.

 

1
Comment actions Permalink

Was able to resolve this by upgrading to latest version of intellij and the python plugin. Turns out the python plugin had a kill-switch hardcoded in:

 

WARN: Python not loaded: until build 173.SNAPSHOT < IU-181.4203.550

 

0
Comment actions Permalink

After updating to 2018.1, I also noticed that "Python SDK" was missing from Platform SDKs "Add new SDK". I resolved by going back to About/Check for updates and found that a bunch of plugins needed updating. After updating and restarting, issue was resolved for me.

0
Comment actions Permalink

Hi Anna,

thank you, enabling the plugins solved the issue.

2
Comment actions Permalink

Thanks Anna, enabling these plugins worked for me too. But this is not very friendly behavior - would be helpful to enhance the product to handle this more gracefully.

0
Comment actions Permalink

I came across a similar issue, for anyone else with a similar issue here are the details. On ubuntu 18.04 the default python is python3, there I found this in the log (see below). It was related to the Restart functionality. After installing python2.7 via apt I got a python binary in the PATH, fixing both the restart function and allowed me to add the python3 SDK that I already had installed.

INFO -   #com.intellij.util.Restarter - not supported: cannot find 'python' in PATH 
0
Comment actions Permalink

It's almost July and I keep installing build updates, when is this going to be fixed? This is a serious issue on a paid product and it is becoming a major issue now that i have to start new projects and I can't setup python SDKs.

We have a license server and over a thousand users. I'd expect this to be fixed a long time ago.

Do you want me to open a Separate issue about this?

EDIT: Installing The dependencies above solve the issue but there is still a lot of users who have this issue and we are spending a lot of time on this. I believe that if those plugins are required by the Python plugin, then they should be enabled when installing the Python plugin. Please make a hard dependency on them. Thanks.

 

2
Comment actions Permalink

It would be very nice to have an option to override the interpreter name check when configuring an SDK. There are other applications which use a custom interpreter name like Maya. I would like to override the name validation and tell PyCharm to use any binary name that acts like CPython (not just a binary starting with "Python")

Additionally, some applications embed Python and provide a Python-mode as a command line flag, for example "MyApplication --python script.py" acts like CPython for the purpose of running script.py. This would also be useful if feasible to support.

0
Comment actions Permalink

Hi Isaiah, mayapy should be supported.

some applications embed Python 

You can attach to such process with PyCharms debugger via Run | Attach to Process, 2018.2 EAP introduced a new option in Settings | Build, Execution, Deployment | Python Debugger which allows specifying a different substring for a process filter (python is a default one).

0
Comment actions Permalink

> Hi Isaiah, mayapy should be supported.

Yes, thanks, what I mean is that I have some arbitrary binary named FooPython or FooPy or anything else (which is actually CPython + some extras underneath), and I want PyCharm to accept that as the interpreter without requiring to have an entire customization class in PyCharm like MayaPy does.

(see https://github.com/Slicer/Slicer/pull/993 for a real example where this happened -- at least in that case we control the binary name, so we can change it)

 

2018.2 EAP introduced a new option

 

Thanks, useful!

0
Comment actions Permalink

Thank you for an example. I've created a ticket in our bug tracker: PY-30953.

0
Comment actions Permalink

Anna Morozova, could you please let me know how to do "Please enable SSH Remote Run and Remote Hosts Access plugins" ?

 

0
Comment actions Permalink

I have installed Python SDK on my Mac machine and can't add in IntelliJ Community edition while on Linux I can do that.

 

0
Comment actions Permalink

I'm having the same problem with 2018.2 but the mentioned plugins are enabled.  Any other tips?

0
Comment actions Permalink

Arthur - JetBrains folks work really hard to provide a product that is free for the vast majority of users. That's not a helpful comment, nor do you have any evidence to back it up.

0
Comment actions Permalink

Thanks Arthur! I believe the team is just busy, but it is frustrating. For what it’s worth, I haven’t seen much traction on my requests either. But I feel like there’s a small team supporting a large user base. Having been on the other side of the equation, I can sympathize. (Although my employer has actually paid for some Ultimate licenses :).

0
Comment actions Permalink

Hi Arthur,

Sorry for a late response.

Please have a look at this page in order to enable plugins https://www.jetbrains.com/help/pycharm/managing-plugins.html

Kind regards,

Sergey

https://www.jetbrains.com

The Drive to Develop

0
Comment actions Permalink

"I have installed Python SDK on my Mac machine and can't add in IntelliJ Community edition while on Linux I can do that." - Please provide more details (screenshot, log folder zipped https://uploads.services.jetbrains.com/ (Help | Show Log in...)). After uploading zip file please provide its name.

Kind regards,

Sergey

https://www.jetbrains.com

The Drive to Develop

0
Comment actions Permalink

Enabling the SSH Remote Run and Remote Hosts Access plugins worked for me. I'm using IntelliJ IDEA Ultimate 2019.2. Previously, when I tried to create a new project, the UI for picking the Python SDK would sometimes be missing. If I clicked on it, it would appear. If I pressed the button to add another Python SDK, it wouldn't do anything. The code was basically wedged. When I added those two plugins, the problem went away.

 

0
Comment actions Permalink

I just wanted to add a "me too" comment for anyone arriving here from Google after updating to 2019.2 -- enabling the SSH Remote Run and Remote Hosts Access plugins worked for me as well.

It would be nice if JetBrains changed the Python plugin to explicitly require these plugins as dependencies to avoid this type of problem in the future.

2
Comment actions Permalink

still occurring as of 2019.2.2

 

I agree with the sentiment that this should be fixed asap, especially if its just a matter of making sure the correct package dependencies are updated.  I wasted at least 20 minutes before I found this thread, which is probably not much more time than it would take to change dependency specification.

 

1
Comment actions Permalink

Just adding another +1; this was happening to me in my new install of IDEA Ultimate 2019.2.4 (Licensed!) and I wasted a good chunk of time trying to figure it out before I found this post.  Adding the SSH Remote Run / Remote Hosts Access plugins fixed it but it's a pretty sharp edge.

1

Please sign in to leave a comment.