Failed to load identity file using ssh, whene I add an SSH interpretr in order to use docker

Answered

 Hi I try to add an SSH interpreter with pycharm( Professional 2018.1),  but I get in the log of docker the message: PAM: Authentication failure for root

root is the user, but on the terminal I connect without problems, you can see the screen capture 

First action:

Second action :log message of docker

 

Third action

 

fourth action

last action






6 comments
Comment actions Permalink

Hi! Could you please create a ticket in our [bug tracker](https://youtrack.jetbrains.com/issues/PY) and attach idea.log from Help | Show Log in ... there? Are you trying to connect with SSH inside a Docker container?

0
Comment actions Permalink

I resolved the problem, the private key must be an rsa,  the key that I had used isn't rsa.

Best regards

 
0
Comment actions Permalink

I see the issue was resolved with 2018.3.1, but I am still having the issue. My key is rsa and it used to work. It stopped after the 2018.3 update. I updated the patch 2018.3.1 but it's still broken.

0
Comment actions Permalink

Like Brian Moran, I'm still having this issue. I'm using 2018.3.1.

0
Comment actions Permalink

Hi Brian and Jianwang,

Are you able to ssh to remote machine using, for example, PuTTY? Have you tried to remove your remote interpreter and add it again from scratch?

If problem remains, please report an issue to https://youtrack.jetbrains.com/issues/PY, add the following lines to Help | Debug Log Settings…, reproduce the problem and attach idea.log (Help | Show Log in...) to the issue.

#com.intellij.ssh
#com.jetbrains.plugins.webDeployment

0
Comment actions Permalink

Thanks Sergey. I have created ticket https://youtrack.jetbrains.com/issue/PY-33131 with some screenshots and debug output.

0

Please sign in to leave a comment.