Linux terminal command "./" results in blank License Agreement


System info:

Red Hat Enterprise Linux Server 7.5 (VM)

java version: "1.8.0_172"

Original install zip: ideaIU-2018.1.5.tar.gz

Name: after unzip: idea-IU-181.5281.24

IntelliJ IDEA: Version: 2018.1.5 Build: 181.5281.24


I cannot open or Run intelliJ on my system because it does not install correctly. 

Steps to recreate problem

  1. Open terminal
  2. cd (directory path to unzipped intelliJ/idea-IU-181.5281.24/bin)
  3. ./


An empty windows with the header/title "IntelliJ IDEA User License Agreement"

The contents of the window are empty. If I click the bottom right corner of the window it closes. I am assuming there must be some type of invisible button there.


The screen shots look a little different then what I am getting. I get a blank white dialog box (Not transparent). In the bug they get a transparent screen.

Also, it looks like everyone has already installed intelliJ. I am coming across this issue right away before the IDE is even run once. I download it, unzip, and try to run the Linux file and the first thing I see is a blank dialog box. Not transparent but just blank with a white background.


Can you run other Java Swing apps on this system? Try JEdit or NetBeans.

Try switching the JVM IDE is using:


I just tried NetBeans and I had the exact same problem I'm having with IntelliJ. On the installation start it shows a blank white screen. I can see the title of the dialog box but nothing inside of it. Do you have any idea what could be causing this issue? I tired googling it and found a bunch of non-related issues... Let me know if you have a solution. Thanks!


You have some system specific issue with running Java Swing applications. It's probably some window manager setting or outdated window manager/video driver package.

If you run it in the VM, try updating the VM software you are using to the latest version, it may be some video driver issue.

Try a different desktop environment, see if any 3D effects are enabled and try disabling them.


In case other folks stumble across this thread like I did: after much tail-chasing I was able to resolve this issue by changing my color depth settings to 24 bits vice the configured 32 bits. I was experiencing this issue over an xrdp connection, so in my case I edited max_bpp in /etc/xrdp/xrdp.ini from 32 to 24. After restarting xrdp my java windows magically started working.


Going to /etc/xrdp/xrdp.ini and changing to max_bpp=24 did the trick!!! everything is working very well now ☺ Thank you very much for helping out!!!


Please sign in to leave a comment.