IntelliJ won't start up

Answered

I'm trying to install IntelliJ for the first time on a system running 64-bit Ubuntu 16.04. When I run idea.sh I see some CPU activity, then it just stops. There are no error messages or output of any kind. I've tried v2018.1 (ideaIU-2018.1.1.tar.gz) and v2017.3.5 (ideaIU-2017.3.5.tar.gz). The SHA256 checksum for ideaIU-2018.1.1.tar.gz matches.

I found ~/.IntelliJIdea2018.1/system/log/idea.log, which contains some output but no errors:
2018-04-20 13:50:41,318 [ 0] INFO - #com.intellij.idea.Main - ------------------------------------------------------ IDE STARTED ------------------------------------------------------
2018-04-20 13:50:41,402 [ 84] INFO - #com.intellij.idea.Main - IDE: IntelliJ IDEA (build #IU-181.4445.78, 09 Apr 2018 13:41)
2018-04-20 13:50:41,402 [ 84] INFO - #com.intellij.idea.Main - OS: Linux (4.13.0-38-generic, amd64)
2018-04-20 13:50:41,402 [ 84] INFO - #com.intellij.idea.Main - JRE: 1.8.0_152-release-1136-b27 (JetBrains s.r.o)
2018-04-20 13:50:41,402 [ 84] INFO - #com.intellij.idea.Main - JVM: 25.152-b27 (OpenJDK 64-Bit Server VM)
2018-04-20 13:50:41,404 [ 86] INFO - #com.intellij.idea.Main - JVM Args: -Xms128m -Xmx750m -XX:ReservedCodeCacheSize=240m -XX:+UseConcMarkSweepGC -XX:SoftRefLRUPolicyMSPerMB=50 -ea -Dsun.io.useCanonCaches=false -Djava.net.preferIPv4Stack=true -XX:+HeapDumpOnOutOfMemoryError -XX:-OmitStackTraceInFastThrow -Dawt.useSystemAAFontSettings=lcd -Dsun.java2d.renderer=sun.java2d.marlin.MarlinRenderingEngine -XX:ErrorFile=/home/scorwin/java_error_in_IDEA_%p.log -XX:HeapDumpPath=/home/scorwin/java_error_in_IDEA.hprof -Didea.paths.selector=IntelliJIdea2018.1 -Djb.vmOptionsFile=/home/scorwin/apps/idea-IU-181.4445.78/bin/idea64.vmoptions -Didea.jre.check=true
2018-04-20 13:50:41,404 [ 86] INFO - #com.intellij.idea.Main - ext: /home/scorwin/apps/idea-IU-181.4445.78/jre64/lib/ext: [localedata.jar, nashorn.jar, sunec.jar, meta-index, sunpkcs11.jar, dnsns.jar, zipfs.jar, jaccess.jar, jfxrt.jar, cldrdata.jar, sunjce_provider.jar]
2018-04-20 13:50:41,404 [ 86] INFO - #com.intellij.idea.Main - JNU charset: UTF-8
2018-04-20 13:50:41,414 [ 96] INFO - #com.intellij.idea.Main - JNA library (64-bit) loaded in 10 ms
2018-04-20 13:50:41,598 [ 280] INFO - #com.intellij.util.ui.JBUI - User scale factor: 1.0
2018-04-20 13:50:41,598 [ 280] INFO - #com.intellij.util.ui.JBUI - System scale factor: 1.0 (IDE-managed HiDPI)

What can I try to get it to start up?

21 comments
Comment actions Permalink

Does the process terminate without errors in the terminal or does it hang forever?

0
Comment actions Permalink

It terminates without errors, after 10 or 15 seconds.

0
Comment actions Permalink

Can you try running from a different user or via sudo?

0
Comment actions Permalink

With sudo it started up and I went through the introductory setup.  I don't have another user to try.

So this could be a permissions problem?

 

0
Comment actions Permalink

Unfortunately, it's not clear what the problem is. We had one user with the similar issue, we were trying different things and didn't solve it. On a clean Ubuntu the issue cannot be reproduced.

0
Comment actions Permalink

I wanted to look for file permission problems so I ran strace:

$ strace -ff -e trace=file "./idea.sh" 2>&1

The output ends with

[pid 12175] stat("/home/scorwin/.fontconfig", 0x7f26c9c13d00) = -1 ENOENT (No such file or directory)
[pid 12175] stat("/home/scorwin/apps/java/jdk1.8.0_144/jre/lib/fonts/fallback", 0x7f26c9c13d80) = -1 ENOENT (No such file or directory)
[pid 12175] open("/usr/share/fonts/truetype/tlwg/Waree.ttf", O_RDONLY) = 234
[pid 12149] --- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_ACCERR, si_addr=0x7f270a89b800} ---
[pid 12141] --- SIGALRM {si_signo=SIGALRM, si_code=SI_KERNEL} ---
[pid 12149] +++ killed by SIGALRM +++
[pid 12181] +++ killed by SIGALRM +++
[pid 12150] +++ killed by SIGALRM +++
[pid 12176] +++ killed by SIGALRM +++
[pid 12148] +++ killed by SIGALRM +++
[pid 12146] +++ killed by SIGALRM +++
[pid 12147] +++ killed by SIGALRM +++
[pid 12175] +++ killed by SIGALRM +++
[pid 12145] +++ killed by SIGALRM +++
[pid 12143] +++ killed by SIGALRM +++
[pid 12177] +++ killed by SIGALRM +++
[pid 12142] +++ killed by SIGALRM +++
[pid 12144] +++ killed by SIGALRM +++
[pid 12141] +++ killed by SIGALRM +++
[pid 12130] +++ killed by SIGALRM +++
[pid 12138] +++ killed by SIGALRM +++
[pid 12131] +++ killed by SIGALRM +++
[pid 12136] +++ killed by SIGALRM +++
[pid 12133] +++ killed by SIGALRM +++
[pid 12180] +++ killed by SIGALRM +++
[pid 12137] +++ killed by SIGALRM +++
[pid 12139] +++ killed by SIGALRM +++
[pid 12132] +++ killed by SIGALRM +++
[pid 12134] +++ killed by SIGALRM +++
[pid 12129] +++ killed by SIGALRM +++
[pid 12182] +++ killed by SIGALRM +++
[pid 12179] +++ killed by SIGALRM +++
[pid 12172] +++ killed by SIGALRM +++
[pid 12135] +++ killed by SIGALRM +++
[pid 12128] +++ killed by SIGALRM +++
[pid 12183] +++ killed by SIGALRM +++
[pid 12122] +++ killed by SIGALRM +++
--- SIGCHLD {si_signo=SIGCHLD, si_code=CLD_KILLED, si_pid=12122, si_uid=1000, si_status=SIGALRM, si_utime=296, si_stime=146} ---
Alarm clock
+++ exited with 142 +++

 

I ran this a couple of times, and the section before the references to SIGALRM changed, but it always ended with many processes being killed by SIGALRM.

1
Comment actions Permalink

Do you use /home/scorwin/apps/java/jdk1.8.0_144 instead of the bundled runtime? Does it help if you switch back? See https://intellij-support.jetbrains.com/hc/articles/206544879.

0
Comment actions Permalink

It's the same behavior with the bundled runtime.  I actually started with idea-IU-181.4445.78 with the bundled 64-bit JDK, and only switched to using my own JDK while trying to troubleshoot this problem.

0
Comment actions Permalink

Can you try to trace what specific processes are started and killed (and their full command lines)? But it's not clear if it's related to the problem.

0
Comment actions Permalink

I'm having the same issue on a 64 bit xenial server install with trinity (kde3) installed.

Idea only runs as root.

Not happy.

0
Comment actions Permalink

I found a better workaround. The reason starting with sudo works is that there are fewer environment variables set. In particular there is this one:
GTK2_RC_FILES=/home/scorwin/.gtkrc-2.0-kde4:/home/scorwin/.trinity/share/config/gtkrc-2.0

If this is not set IntelliJ will start up successfully for me.

I created a shell script for convenience:
$ cat startIdea.sh
#!/bin/bash
unset GTK2_RC_FILES
/home/scorwin/apps/idea-IU-182.4505.22/bin/idea.sh


The same approach works for running Android Studio.

0
Comment actions Permalink

Experienced also sigsegv when starting pycharm. I tried another jre and also a fresh download of pycharm (2018.3.5) but it kept on crashing.

➜ bin ./pycharm.sh
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f00b3b87731, pid=4341, tid=0x00007f009c2fa700
#
# JRE version: OpenJDK Runtime Environment (8.0_152-b28) (build 1.8.0_152-release-1343-b28)
# Java VM: OpenJDK 64-Bit Server VM (25.152-b28 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# V [libjvm.so+0x3fa731] PhaseChaitin::gather_lrg_masks(bool)+0x131
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /home/paul/java_error_in_PYCHARM_4341.log
[thread 139638650844928 also had an error]
^CAborted (core dumped)

I resolved it by removing the pycharm folder in my ~:

➜ bin mv ~/.PyCharm2018.3 ~/.PyCharm2018.3_

Then it started again; seems some files got corrupted there and pycharm cant handle it.

Paul

 

0
Comment actions Permalink

Please report at https://youtrack.jetbrains.com/issues/JBR with /home/paul/java_error_in_PYCHARM_4341.log attached.

0
Comment actions Permalink

Hi guys,

 

My intellij meet the same issue after upgrade to 2019.3.3. 

sudo ./idea.sh works but ./idea.sh not. Intellij quit peacefully. 

But after I run  "strace -ff -e trace=file "./idea.sh" 2>&1", magic happened.  Intellij run without issue (but slowly with verbose log).

After Intellij stabilized and I closed the Intellij restart again without strace. My intellij works again!

so  thanks a log @Scorwin for save my day!

 

Ming

0
Comment actions Permalink

Same issue with PyCharm Pro 2021.1.1 on Ubuntu 20.04.

For me as well, this works with sudo.

I'm using docker containers for most of my python work and have the feeling that a container might have registered something as root.

PyCharm installed using `snap`, for what it's worth...

`strace` does not solve the issue for me, I fear.
Is there somewhere I could upload the strace log to? WIth 3.4mb it's too large for pastebin

0
Comment actions Permalink

We had several reports that Cortex XDR anti malware agent is affecting startup of our IDEs. Please try uninstalling it if you have one.

0
Comment actions Permalink

I'm not an expert, but something called *... anti malware agent* doesn't sound like a thing I'd like or should uninstall. Is there another way?

 

0
Comment actions Permalink

Ido Freeman You may uninstall Cortex XDR anti malware agent as a troubleshooting step. In case this program really prevents IDE from start, try to add IDE to the exclusions list or something like that. Choosing another antivirus is also an option. 

 

0
Comment actions Permalink

It seems like Cortex XDR is not installed on my machine

0
Comment actions Permalink

Any other antivirus? 

You may share console output, strace logs and whole issue descriptions at YouTrack: https://youtrack.jetbrains.com/newIssue?project=IDEA

There is a possibility that your case is different from the one discussed in this thread. 

0
Comment actions Permalink

Nothing I've explicitly installed/ I'll make sure to open a new ticket.

 

Edit: https://youtrack.jetbrains.com/issue/IDEA-268553

0

Please sign in to leave a comment.