How to remove MaxPermSize from run configuration VM options?

Answered

When I run a JUnit test with a Project SDK of JDK 8 I get a warning for MaxPermSize:

Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=500m; support was removed in 8.0

The test is launched with the following command line:

/Library/Java/JavaVirtualMachines/jdk1.8.0_181.jdk/Contents/Home/bin/java -ea -Xmx1g -XX:MaxPermSize=500m [...]

If I check Run > Edit Configurations... > Templates > JUnit, the only VM option set is '-ea', so it would seem the other options are being added by default.

Is there a way to configure these defaults to remove the '-XX:MaxPermSize' option?

 

IntelliJ IDEA 2018.2.1 (Ultimate Edition)
Build #IU-182.3911.36, built on August 6, 2018
JRE: 1.8.0_152-release-1248-b8 x86_64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.13.6

1
2 comments

Is that a Maven project?

These options may be taken automatically from your pom.xml configuration, controlled by the following options:

If it's the case, I'd recommend editing your pom.xml and removing the option from there.

3

It is!  Thanks, I didn't even think to look there.

0

Please sign in to leave a comment.