pycharm has become unworkable, a total reset should fix the problem


It all started when I created 300,000 files amounting to about 1 gig.  Pycharm couldn't index them and I started getting the error message: 'generating skeletons'.  I moved the large files outside of the folder which Pycharm indexes but that is not making the problem go away.  I am now encountering a lot of problems, probably the most damaging is that it no longer alerts me of misspelled words or unresolved references.  I have redownloaded the software twice and have used three different versions (2017.3, 2018.1, 2018.2).  All of them are suffering from this problem but 2017.3 less so. I have also tried invalidating the caches and resetting but that has not helped. The large files which started the problem are now moved away so if I could just redownload pycharm and reset everything to the default settings then I should think that should solve the problem but I cannot figure out how to do that. 

I am also having problems with saving files (some of my code has disappeared) and also the color schemes are no longer working. Still another problem is that pycharm cannot find files in my folders. 


Ok, looks like I solved the problem.  I thought the location I moved the bad file to was outside of the folders that pycharm was indexing but it wasn't. Still, you might want to look into how to inform users what causes that problem and how to write an error message so that they can fix it.



Thank you for contacting PyCharm support.

If the problem reoccurs please provide your logs folder zipped (Help | Show Log in...) and also  capture a CPU snapshot as described in Just upload them to and provide the name of zip file.

Kind regards,


The Drive to Develop


Please sign in to leave a comment.