PyCharm does not show modules in site-package in a remote virtual env project

Answered

While I can remote debug a dango project successfully,  PyCharm does not show modules in site-package in the remote virtual env.

( because I cannot see source code, "remote debug" above means just I can "Run"->"Debug" from menu. )

* modules such as django are successfully installed in the virtual env and can run web server.

12 comments

Hi yukilab,

Thank you for contacting PyCharm support.

Is it `Settings/Preferences | Project | Project Interpreter` what you are looking for? Here you are able to view all the packages installed to your remote interpreter.

Please correct me if I have misunderstood.

Looking forward to your reply.

Kind regards,

Sergey

https://www.jetbrains.com

The Drive to Develop

0

Hi Sergey, no.

What I'm pointing is Project Explorer -> External Libraries as attached image. In typical projects I saw remote libraries under site-package but this time I don't see even site-package itself.

 

Remote packages installed in remote virtual environment can still be seen in 'Settings/Preferences | Project | Project Interpreter' UI though.

0

Does directory exist on your remote machine for this interpreter?

It could be that this directory doesn't exist and thus is not shown in PyCharm.

You could also browse remote host (Tools | Deployment | Browse Remote Host).

Kind regards,

Sergey

https://www.jetbrains.com

The Drive to Develop

 

0

Yes. Modules exist in the site-package directory and can be browsed with Tools | Deployment | Browse Remote Host

0

Oh, I see.

What is your PyCharm version?

Could you please check latest EAP build? https://www.jetbrains.com/pycharm/nextversion/ There're a bunch of related fixes in it.

Kind regards,

Sergey

https://www.jetbrains.com

The Drive to Develop

0

Thank you for prompt support, Sergey,

I was using 2018.2.4.   I have updated PyCharm following given link and now it is 2018.3 EAP.  Issue remains same though even re-assigned / indexed project interpreter. 

0

1) Please add the following lines to Debug Log Settings as described here https://youtrack.jetbrains.com/issue/PY-22254#focus=streamItem-27-3055432-0-0. Then reproduce the problem and attach your idea.log (Help | Show Log in...).

2) What is OS of your server?

Kind regards,

Sergey

https://www.jetbrains.com

The Drive to Develop

 

0

Sergey,


1)  Please find log at https://gist.github.com/yukilab2/f5d6f1f7460afb829dee77249439dc31.  (this site does not allow attaching files other than jpeg, gif or png)

2) local server is macos; remote server is ubuntu 16.04LTS.

BR

 

Tha

0

The link doesn't seam to be working for me, sorry. Please upload it zipped to https://uploads.services.jetbrains.com/ with some different name and provide the name of the zip file so we can find it.

Thank you!

Kind regards,

Sergey

https://www.jetbrains.com

The Drive to Develop

0

Nope, was some glitch, I was able to access it with your link.

Thanks!

0

Hi yukilab, thank you for the logs, I created a ticket in our bug tracker for a responsible developer to investigate https://youtrack.jetbrains.com/issue/PY-32035 Please follow it for updates and feel free to remove the gist.

0

thank you Pavel and Sergey. I follow the ticket.

0

Please sign in to leave a comment.