PyCharm ignores Run Configuration and starts a plain Python Console

Answered

I am using PyCharm professional 2018.2 with a remote ssh interpreter.

Whenever I try to run any python file, PyCharm just opens up a python console and ignores my file entirely.

I tried looking at my Run Configuration and I noticed the PYTHONUNBUFFERED environment variable was missing, so I set it to 1, saved the configuration, and ran it again, but the same thing happened. What's even weirder is that after running, PYTHONUNBUFFERED was missing from my configuration's environment variables... AGAIN!

The only way I can get my code to run is by unchecking the "Run with Python console" option in the Execution section of the Run Configuration, but I'd like to be able to interact with an active console when my code finishes. Also, debug works just fine...

3 comments

Hi Zohar,

Would it be possible to attach a screenshot with your Run/Debug Configuration and a screenshot with your Python Console configuration (Settings/Preferences | Build, Execution, Deployment | Console | Python Console)?

0

Hi Sergey,

Here is a screenshot of my run configuration:

and here is the Python Console config:

Thanks :)

0

Please sign in to leave a comment.