double call of python interpreter when debugging


Hi all,

I've been working with activating conda env from python script and probably by mistake modified the way my interpreter starts. I ended up with a bash script generated from python script and calling it by subprocess.Popen(...)

Now to the problem, every time I'm in debugging mode and calling console in Pycharm, I have doubled interpreter start which slows down a lot the process.

One thing I remeber had to do with conda itself that asked me to copy some lines to my ~/.bashrc however I don't remember what exactly though. Can anyone help me please?? 

import sys; print('Python %s on %s' % (sys.version, sys.platform))
Python 3.6.6 |Anaconda, Inc.| (default, Jun 28 2018, 17:14:51)
Type 'copyright', 'credits' or 'license' for more information
IPython 6.3.1 -- An enhanced Interactive Python. Type '?' for help.
PyDev console: using IPython 6.3.1
Python 3.6.6 |Anaconda, Inc.| (default, Jun 28 2018, 17:14:51)
[GCC 7.2.0] on linux
Out[2]: <__main__.Controller at 0x7f7854037da0>


 also, it seems that debugging itself is super slow when working with big arrays (like TIFF image 30MB converted to array by mpimg.pil_to_array). is there a way to somehow accelerate it? 



Does unchecking Use IPython if available option under Settings/Preferences | Build, Execution, Deployment | Console help?

Please attach a screenshot of your Run/Debug Configuration and a screenshot showing this problem in PyCharm.


It kinda worked, thanks. I think the problem was partly because of the heavy files I operated with


I just ran into this problem when just running the script. Unchecking "Use iPython if possible" worked. Could somebody elaborate a little on what unchecking this options means, and why the script would be executed twice when it's checked?


Please sign in to leave a comment.