Pycharm 2018.3 remote interpreter via WSL hangs

Answered

Hi,

I'm trying to get the new remote interpreter via WSL feature from update 2018.3 to work. Pycharm hangs on the "getting remote interpreter version" prompt. Here's a link to a stackoverflow question i opened recently with more details: https://stackoverflow.com/questions/53438173/pycharm-2018-3-remote-interpreter-via-wsl-hangs 

Does anyone know what the issue could be ?

Thanks in advance,

7 comments

Hi Marco,

Please try starting with defaults by renaming/removing this folder:

<SYSTEM DRIVE>\Users\<USER ACCOUNT NAME>\.<PRODUCT><VERSION>

Does it help?

0

Hi Sergey,

Thanks for the suggestion. Unfortunately the issue still persists after trying that. Anything else I could try ?

0

Please clarify what is your Windows version? It should be the latest one.

Please also make sure that WSL is running on your machine. Does it work correctly?

Currently, it seems like PyCharm is simply waiting for some response.

0

OS Name: Microsoft Windows 10 Enterprise
Version: 10.0.16299 Build 16299

WSL works correctly on my machine. In fact, as a work around I'm using the "remote interpreter via SSH" option instead of WSL. I setup pycharm to SSH to my WSL (Ubuntu) and works fine, so WSL must be working correctly on my machine. I'm really not sure why Pycharm hangs when I tried to use the WSL option. Also, whenever I tried to use the WSL option, I have to force quit Pycharm using the task manager.

In summary, I managed to get my dev setup to work by using the SSH option (SSH-ing to my WSL) instead of WSL option. But it would be great if I could get WSL option to work :)

0

If PyCharm becomes unresponsive, then it looks like a performance problem. It should not hang even when waiting for some connection.

Could you please reproduce the problem and then upload your renamed logs folder zipped (Help | Show Log in...) to https://uploads.services.jetbrains.com/ and let me know the name of that zip file?

0

Hi Sergey,

I've uploaded the zip file. The name is wsl_hangs_log.zip

0

Thanks!

I have filed a performance problem issue to our issue tracker https://youtrack.jetbrains.com/issue/PY-32923, please follow it for updates.

1

Please sign in to leave a comment.