process is not allowed to run in parallel

Answered

Hi Folks. I just downloaded the 2018.3 update, and now I get a new-to-me message when I try to run multiple RQ (in Django) worker processes:

Process 'manage.py rqworker postgres' is Running.
'manage.py rqworker postgres' is not allowed to run in parallel. Would you like to stop the running one?

I don't know for sure if the update changed this, but this is the first time intellij has stopped me from running more than one. Did something change? Thanks.

26 comments
Comment actions Permalink

Hello Matthew,

The default behavior was changed to "single instance only" for run configurations in 2018.3. Could you please enable Allow running in parallel option in the corresponding run configuration?

 

0
Comment actions Permalink

That fixed it, Yaroslav. Thank you. Question: Why the change?

0
Comment actions Permalink

Hi,

I am running an application on Tomcat and have the same problem. But I don't see the option "Allow running in parallel" in run/debug configurations. Should I find it somewhere else for tomcat?

Thank you

1
Comment actions Permalink

Hello,

It's a natural behavior of an application server run configuration. Even if you were allowed to start Tomcat run configuration twice, the server itself would not start for the second time since HTTP/JMX port would be already occupied by the first instance.

The second run configuration for the same application server but with different port numbers always should be configured to have 2 servers running at the same time.

Clicking "Run" should invoke "Update" action, but there is known issue with it: https://youtrack.jetbrains.com/issue/IDEA-203047

 

0
Comment actions Permalink

Oh okay, I didn't realize. It's a very annoying problem though.

0
Comment actions Permalink

We'll try to provide fix as soon as possible.

0
Comment actions Permalink

Thanks for the clarifications, I was also wondering about this behaviour. 
I also don't understand why this was changed, I'm very much used to having same run configurations, especially tests, run in parallel. 

So other people were complaining that all run configurations by default should be singleton. But I guess it was never surveyed, how many people are opposed to such a behaviour. Maybe a project or IDE-wide setting for a default value would be nicer instead of forcing such a behaviour on the user.

0
Comment actions Permalink

Echoing Michaela above: Running Tomcat, where can I find the option to allow running in parallel?

0
Comment actions Permalink

This had become a major block for our project so I reverted to the previous (Nov 21) version. Not planning to upgrade until I know for a fact this is fixed.

0
Comment actions Permalink

Unfortunately, reverting to 18.3 and restarting the machine didn't help. It looks like the damage is deeper. Any ideas?

0
Comment actions Permalink

Reverting to 2018.2, as Serge suggested, solved the problem for me. Support was really fast and I was back in business the same day; thanks, Serge! :)

0
Comment actions Permalink

I haven't updated IDEA for a while for fear of re-introducing this issue. Does anyone know if this has been fixed in latest releases?

0
Comment actions Permalink

This issue was resolved and should not affect current IntelliJ IDEA version.

0
Comment actions Permalink

Just upgraded and it seems to be working like a charm. Thanks!

0
Comment actions Permalink

It still affects the newest version of IntelliJ on Manjaro (Arch Linux)...

 

0
Comment actions Permalink

Magne, please provide more details. Did you enable Allow running in parallel option? Or do you have some different problem?

0
Comment actions Permalink

It works now after enabling the parallel running option.

0
Comment actions Permalink

Hi I had encountered the same problem when I was trying to run parallel tests for JavaScript / TypeScript with Jest.

Contradictory to the documentation specified in the help page, I could not see the common option "Allow running in parallel" when I opened the "Run/Debug Configuration" dialog (could only see the "Share" option which did not solve the problem even when checked).

Version: IntelliJ IDEA 2019.1 (Ultimate Edition) Build #IU-191.6183.87, built on March 27, 2019

 

Any information / help would be appreciated. Thanks.

0
Comment actions Permalink

Jest configuration type is SINGLE_INSTANCE_ONLY, there is no way to run several Jest configurations in parallel. Why do you need running several instances concurrently?

0
Comment actions Permalink

Can't find the "Allow Running in Parallel" option in the Application template Run/Debug Configuration. 

 

0
Comment actions Permalink

Modify options | Allow multiple instances:

0
Comment actions Permalink

Alright, Thank You!

0
Comment actions Permalink

I don't see "Modify options" either. What's going on?

0
Comment actions Permalink

Hello Dialagain,

Are you able to access them via Alt + M? Try to temporarily disable all third-party plugins.

If the problem remains please contact our support team at https://intellij-support.jetbrains.com/hc/en-us/requests/new , and provide the IDE logs. (Help | Collect Logs and Diagnostic Data)

0

Please sign in to leave a comment.