Solved: Terminal will not return to docked mode

I've seen several posts on this issue, but none of the solutions presented are working.  This issue has been plaguing me for a while now.  At this time I'm using webstorm v2018.3.  When I recently started a new project the terminal is docked, but for my primary project it will not dock with the following solutions.

 

1) With the terminal in windowed mode, if I deselect windowed mode from the termainal it goes to floating mode.

2) In the menu Window > Active Tool Window the option to go to docked mode is greyed out.  If I deselect windowed mode from this menu it goes to floating mode, and docked mode is still greyed out.  

 

If anyone has a solution, I'm all ears, this is extremely frustrating.

4 comments
Comment actions Permalink

Looks similar to https://youtrack.jetbrains.com/issue/IDEA-187306..

Deleting project .idea/workspace.xml should help to restore the default layout, but it's not the best solution of course...

1
Comment actions Permalink

Yes seems similar to that issue, doesn't seem to provide any new solutions though.  Tried Shift+F12 as well.  That seems to minimize the terminal, but doesn't dock it back into the IDE window.

0
Comment actions Permalink

Elena, your "not the best solution" ended up pointing me in the right direction.  I went into the workspace.xml for the newer project where this isn't an issue and copied the line below.  I replaced the terminal line in the problematic project with this line and it seems to be working now.  I wish the solution was more straight forward than that, but at the end of the day I'm just happy to have my terminal docked again.  Thanks!

 

<window_info id="Terminal" active="true" weight="0.2487725" visible="true" order="10" anchor="bottom"/>

2
Comment actions Permalink

Hi everyone! Today I bumped with the same problem. After reading your comments I modified the method:


1. Close the project

2. open file .idea/workspace.xml (located in project folder) and found the line where id="Terminal" is located

3. on this line delete type="FLOATING"

4. Reopen the project

Really annoying issue, hope Jetbrains team will fix it.

0

Please sign in to leave a comment.