Cannot import setting on PhpStorm 2018.3.2

Just upgraded from 2018.2 to 2018.3.2, saved my settings beforehand to a .jar file, then installed the new version but it didn't retain all my color/theme settings, such as the background color of the editing window.

This has happened before and I usually just re-import my old settings, however now, for some reason it won't let me, it complains it cannot find a setting.zip file; why is it looking for a ZIP file when it exported it as a JAR file!?

Very annoying!!!

4 comments

There's no need to use the .jar file to import settings - please remove (or better temporarily rename) the .PhpStorm2018.3 config directory, start PhpStorm and import your settings directly from the .PhpStorm2018.2 directory.

You can find the config directory location with the help of this article: https://intellij-support.jetbrains.com/hc/en-us/articles/206544519

0

Thanks for that, I will use that method next time. However, this still doesn't change the fact that importing settings is broken since it isn't looking for .jar files, only .zip files. This means if I wanna take my settings to another installation I won't be able to do that.

0

I should also mention when I installed 2018.3 I selected to import my settings from the config folder it preselected, but as I said, whilst it brought in most of my settings it failed the ones mentioned previously, that's why I had to do the file import, which in this instance I couldn't do.

0

Just in case, I tried to reproduce the issue.

Exported 2018.2.6 settings (just Code Style) to .jar file and was able to successfully import it in 2018.3.3. Could you please try installing 2018.3.3 and check if it works for you?

A couple of noticed facts though:

- Unlike 2018.2, version 2018.3 now suggests .zip file as default during export;

- There is a similar report with .jar import for Rider:

https://youtrack.jetbrains.com/issue/RIDER-22823

0

Please sign in to leave a comment.