Cannot start process, the working directory '\setuptools-39.1.0' does not exist

 Hi all,

 

When attempting to create a project using virtualenv I get the error:

 Cannot start process, the working directory '\setuptools-39.1.0' does not exist

 This is on PyCharm 2018.3.2 on Windows 10.  I've included the relevant log file lines below.  For some reason the packaging tool tries to run the setuptools setup.py from a quasi relative path rather than the temp folder where setuptools was untarred (I know this as I've debugged running the packaging tools untar function manually and it works fine).  

2019-01-03 15:14:50,618 [ 82434] INFO - packaging.PyPackageManagerImpl - Running packaging tool: C:\Support\Projects\xxx\venv\Scripts\python.exe C:\Support\Programs\PyCharm 2018.3.2\helpers\packaging_tool.py untar C:\Support\Programs\PyCharm 2018.3.2\helpers\setuptools-39.1.0.tar.gz
2019-01-03 15:14:55,258 [ 87074] INFO - packaging.PyPackageManagerImpl - Running packaging tool: C:\Support\Projects\xxx\venv\Scripts\python.exe \setuptools-39.1.0\setup.py install

 Any guidance would be appreciated.

Thanks,

Naed

 

1 comment

Hi Naed,

You're right, PyCharm extracts setuptools-39.1.0.tar.gz into temp folder and run it from there. Do you recall making any changes to your OS prior to the issue? Although this is a long shot, please also check your %TEMP% and %TMP% environment variables, do they point to correct temp folder?

Have you tried re-installing PyCharm?

0

Please sign in to leave a comment.