Find in Path shows max 100 results

Answered

Hello,

I'm facing with an annoying issue regarding the "Find in Path".

I'm using the latest version of IntelliJIDEA and when I press Ctrl+Shift+F and I open the "Find in Path" dialog to search for a word, if the results are > 100 the dialog show only the first 100 results.

How can I make it to show all the results of the search?


Thank you in advance,

Best regards

Denis

6 comments
Comment actions Permalink

See https://youtrack.jetbrains.com/issue/IDEA-157855.

Adding -Dide.usages.page.size=1000 in Help | Edit Custom VM Options and restarting IntelliJ IDEA will change the limit to 1000.

Open in Find Window button will show all the results.

10
Comment actions Permalink

Thank you Serge, It works like a charm.

Regards,

Denis

1
Comment actions Permalink

Thanks - I've been wanting that a long time

0
Comment actions Permalink

Is the solution shown above (link here) still valid? It worked on a previous version of CLion; however, it looks like it's no longer working and now back to defaulting to 100.

CLion 2021.2
Build #CL-212.4746.93, built on July 27, 2021

0
Comment actions Permalink

In 2021.2 the limit is configurable in Settings (Preferences on macOS) | Advanced Settings | Maximum number of results to show in Find In Path/Show Usages preview.

3
Comment actions Permalink

I see it now - that works. Thanks for the prompt response!

0

Please sign in to leave a comment.