PyCharm Remote Docker Interpreter Error: OCI runtime create failed

Completed

Hi, I am getting this error when trying to set up a remote docker interpreter for my PyCharm project. I have seen a similar error in other posts, but no solutions from those are working for me. I have tried deleting/restarting all docker containers and images, as well as restarting/clearing cache of PyCharm. I am using PyCharm 2018.3.4.

 

Any help would be appreciated. Thanks.

 

4 comments

Does rebuilding image help?

Please attach a screenshot of your interpreter configuration when you create it and a screenshot of Docker configuration Settings/Preferences | Build, Execution, Deployment | Docker

Try running docker run hello-world from the system terminal. Does it work fine?

0

I tried rebuilding the image but unfortunately that did not help either. 

Here is the screenshot from when I try adding the project interpreter: I've tried python, python3, and /usr/local/bin/python3.7 for the Python interpreter path.

Here is the Docker configuration:

 

and by running the hello-world script in Terminal I get the correct output.

0

It seems that you are running debian:stretch docker image, and it seems this image does not have python interpreter installed.

I've tested by simply pulling debian:stretch , then bash into it:

    docker run -it debian:stretch /bin/bash

And while I'm inside the container, no interpreter is found:

    root@7b10e512906e:/# python
    bash: python: command not found

Please try using another image, like python:latest

0

This fixed the problem. Thanks!

0

Please sign in to leave a comment.