I don't want auto format when pasting yaml property names


Hi, after the latest update 

IntelliJ IDEA 2018.3.4 (Ultimate Edition)
Build #IU-183.5429.30, built on January 29, 2019


An annoying bug/feature has turned up.


When I paste  ```foo.bar.baz : 'value' ```  in a yaml file it auto corrects it to  ```foo: \n bar: \n baz: 'value' ``` which is never what I want.

This really starts to annoy me and I would like to know how to turn that off, without breaking the other code formatting features for yaml.


There doesn't seem to be a way to control this behavior. It's a result of this feature: https://youtrack.jetbrains.com/issue/RUBY-21518 .

Feature request for the YAML formatter option is welcome at https://youtrack.jetbrains.com/issues/RUBY.


This feature is really annoying in phpstorm too, is there any issue to vote for?


the issue is https://youtrack.jetbrains.com/issue/IDEA-212933, the fix will be available on all platforms.


Please sign in to leave a comment.