How to disable PyCharm line wrapping?

Answered

How do I disable this?  It turned on recently after updating PyCharm and I'm not a fan.  I've found some 6-year-old posts saying how to do it, but much has changed since then.  

 

Thanks

 

5 comments
Comment actions Permalink

I believe Use soft wraps in editor under Settings/Preferences | Editor | General should do the trick.

0
Comment actions Permalink

So I have that turned off.  Should it be on or off?  It's still happening with it both checked and unchecked.  

 

0
Comment actions Permalink

I think I see what's going on here.  Use soft wraps does seem to be the right setting, but it's broken in one file.  In most of my source code it works just fine.  But one of my files is over 20,000 lines long.  And in that one, for some reason, soft wrap is always on regardless of what I check in that box.  Even when I restart PyCharm it still does the soft wrap when that box is unchecked.  


I wonder if intellisense (or whatever is doing the soft wrap) is crashing in large files.  

0
Comment actions Permalink

Hmmm, I couldn't find relevant bug report for that. Please feel free to report one to https://youtrack.jetbrains.com/issues/IDEA

0
Comment actions Permalink

I think I found the problem.  I saw a warning flash at the top when I restarted PyCharm.  Looks like this isn't a bug and is actually a feature!

0

Please sign in to leave a comment.