PYCharm Installation and interpreter conflict

Answered

so i tried to install pycharm and got several problems. 

1. i realized i had no pyhton on my pc. so i installed python 3.7.2 because i thought this might work. 

2. i installed pycharm and wanted to import a project of a friend. so i dragged it into the project foulder and started the program but i couldn't work with the project, although it worked before on another pc without problems.

When i try to run s part of the project the program says: i have to chose an interpreter. i did so and now the program says that its incompatible with the project. But why? 

it says cannot setup python sdk at python 2.7

what does this mean? 

Also it says things like: 

Traceback (most recent call last):
File "C:\Users\****\PycharmProjects\Python RPG\venv\lib\site.py", line 703, in <module>
main()
File "C:\Users\****\PycharmProjects\Python RPG\venv\lib\site.py", line 692, in main
aliasmbcs()
File "C:\Users\****\PycharmProjects\Python RPG\venv\lib\site.py", line 515, in aliasmbcs
import locale, codecs
File "C:\Users\lkebel2\PycharmProjects\Python RPG\venv\lib\locale.py", line 19, in <module>
import functools
ImportError: No module named functools

 

i relly hoped.. one time for an easy to use environment... *sigh*

i have a windows 10 pc 64x with 3.2.7 python installed. 

 

 

2 comments

Hi,

Please provide a screenshot of your Project Interpreter (Settings | Project | Project Interpreter) and the whole console output.

0

Already found out what the problem was. 

i Installed the 64bit 3.2.7 Version of Python on my pc. The Version my Friends program was written in was 2.x and 32bit. This caused a conflict in syntax and my Pycharm was not able to use the toolchains needed. I deinstalled Python and Pycharm and reinstalled the correct version. Now its working. 

 

0

Please sign in to leave a comment.