Weird behavior for beginning commas

Completed

I have the code formatter setup mostly how I like it, but I'm getting really weird behavior from the select statement's settings for beginning with a comma. When run, it's moving the comma from the end of the column (as desired), but it's also adding in a new line. I don't see an obvious way to turn off this behavior. Have I missed something?

6 comments
Comment actions Permalink

@Jacob Mastel Could you email me vasily.chernov@jetbrains.com your DG settings?

0
Comment actions Permalink

Which version of DataGrip do you use, and which dialect (DBMS type)?

 

0
Comment actions Permalink

Vasily:

I have emailed you directly. Thank you for looking into this.

Leonid:

I'm using the latest version of DataGrip, with a standard ANSI dialect. It doesn't appear to make a difference between Oracle or SQL Server though.

0
Comment actions Permalink

Jacob, I couldn't reproduce it in DataGrip version 18.3.3. Please attach your settings and the text (as a text, not as a picture).

P.S. the only case when I could reproduce it is when the option to keep line breaks when reformatting is ON, but it's the expected behaviour of the formatter (it keeps users line breaks, as asked). Please check that that option is OFF.

0
Comment actions Permalink

I'm experiencing the same issue: DataGrip 2019.2.5;  MS SQL (no issues in other dialects). The problem only occurs when the top N clause is used. Example (after auto-formatting) below. The issue also occurs with default setting.

0
Comment actions Permalink

Guys, sorry for the delay. I'll fix it ASAP.

Please follow this bug in our issue tracker: https://youtrack.jetbrains.com/issue/DBE-9458

Thanks for the bug report.

1

Please sign in to leave a comment.