Connection to Python debugger failed: Accept timed out

Answered

I have issues with attaching to process on ubuntu 18.04.2 LTS, Python 2.7.15rc1. I set up system:

kernel.yama.ptrace_scope = 0

When I'm trying attach to process I get timeout error (I can see Connection to Python debugger failed: Accept timed out in event log)

Attaching to a process with PID=10619
/home/t/Desktop/venv/bin/python /home/t/pycharm-professional-2018.3.4/pycharm-2018.3.4/helpers/pydev/pydevd_attach_to_process/attach_pydevd.py --port 39311 --pid 10619

Process finished with exit code 0
Server stopped.

I tried to use another IDE (liclipse and attaching to process worked)

3 comments
Comment actions Permalink

Hi,

Does it happen with some particular process or is it reproducible if you run python from system terminal and then try to attach to it from within PyCharm?

Please upload your renamed idea.log from Help | Show Log in.. after reproducing the problem to https://uploads.services.jetbrains.com/ and let me know the name of the file.

0
Comment actions Permalink
file names:
attach-to-proc.gif (264 kb)
attach-to-proc-idea.log (743 kb)
 
 
0
Comment actions Permalink

Thanks!

Alright, it seems to be the same problem described here https://youtrack.jetbrains.com/issue/PY-30064

It is currently In Progress which means we are working on the fix for it. Please follow the issue for updates to be notified when the fix comes.

0

Please sign in to leave a comment.