PyCharm 2018.3 Terminal Keybinding Switches to First Tab

Answered

In prior versions of PyCharm (at least in 2018.1.4 and before), if I had multiple tabs open in the terminal and used a keybinding to switch from the editor to the terminal, it would focus on the terminal tab I was most recently in. (i.e. if I had 3 tabs and was working in tab 2, switched to the editor and then switched back to the terminal, it would just focus back into tab 2.) Since updating to PyCharm 2018.3, whenever I use the keybinding to switch back to the terminal, it automatically switches to the first tab.

Slightly related, but a different issue, it seems I can no longer re-order terminal tabs by dragging them. Is there a fix for either of these?

Thanks!

3 comments
Comment actions Permalink

Hi,

The problem with tabs reordering is known https://youtrack.jetbrains.com/issue/IDEA-202809, please vote for it and follow for updates.

Can't reproduce your problem with switching between terminal and editor though. How do you switch between them?

0
Comment actions Permalink

Reviving this because it's still an issue for me in 2019.2.5 (macOS 10.15.1 Catalina).

Strangely, I've found that it's only a problem with keyboard shortcuts that include the shift key. If I use the default keybinding of option+f12, it switches to the currently open tab (desired behavior), the same is true if I do option+cmd+9. However, if I use any of option+shift+9 or shift+cmd+9, option+shift+cmd+9, it switches to the first tab in the terminal (undesired behavior). Any ideas why this could be?

0
Comment actions Permalink

Extremely strange issue but I can reproduce it. Please follow: https://youtrack.jetbrains.com/issue/IDEA-228274

 

0

Please sign in to leave a comment.