Cannot create new projects except base interpreter

Answered

I've been trying to create a project with a virtual environment (virtualenv / venv), but cannot actually get a project to be created.

The only way I've been able to create a project has been using system interpreter - /usr/bin/python, which I don't want to rely on / use.

My most recent attempt was with a 3.7 interpreter, and it just hung after pressing the create button.

I've even tried hard deleting and reinstalling PyCharm CE, but to no avail.

A small snippet of the end of my logs:

2019-03-06 15:15:58,281 [   8716]   INFO - ellij.project.impl.ProjectImpl - 15 project components initialized in 76 ms

2019-03-06 15:15:58,537 [   8972]   WARN - til.ui.update.LazyUiDisposable - use application as a parent disposable

2019-03-06 15:16:00,363 [  10798]   WARN - til.ui.update.LazyUiDisposable - use application as a parent disposable

2019-03-06 15:16:31,059 [  41494]   INFO - ellij.project.impl.ProjectImpl - 88 project components initialized in 160 ms

2019-03-06 15:16:31,060 [  41495]   INFO - le.impl.ModuleManagerComponent - 0 module(s) loaded in 0 ms

2019-03-06 15:16:31,125 [  41560]   WARN - rationStore.ComponentStoreImpl - Cannot find virtual file null

2019-03-06 15:16:31,160 [  41595]   INFO - j.ide.script.IdeStartupScripts - 0 startup script(s) found

2019-03-06 15:16:31,247 [  41682]   WARN - j.ui.mac.MacMainFrameDecorator - no url bundle present.

To use platform protocol handler to open external links specify required protocols in the mac app layout section of the build file

Example: args.urlSchemes = ["your-protocol"] will handle following links: your-protocol://open?file=file&line=line

2019-03-06 15:16:31,357 [  41792]   INFO - rojectCodeStyleSettingsManager - Initialized from default code style settings.

2019-03-06 15:16:31,648 [  42083]   INFO - .diagnostic.PerformanceWatcher - Post-startup activities under progress took 51ms; general responsiveness: ok; EDT responsiveness: ok

2019-03-06 15:16:31,810 [  42245]   INFO - .diagnostic.PerformanceWatcher - Pushing Python language level to 0 roots in 0 SDKs took 1ms; general responsiveness: ok; EDT responsiveness: ok

2019-03-06 15:16:31,891 [  42326]   INFO - packaging.PyPackageManagerImpl - Running packaging tool: /usr/local/bin/python3.7 /Applications/PyCharm CE.app/Contents/helpers/packaging_tool.py pyvenv /Users/xbbnw7r/PycharmProjects/untitled3/venv

2019-03-06 15:16:31,897 [  42332]   INFO - .diagnostic.PerformanceWatcher - Pushing properties took 28ms; general responsiveness: ok; EDT responsiveness: ok

2019-03-06 15:16:32,408 [  42843]   INFO - .diagnostic.PerformanceWatcher - Indexable file iteration took 510ms; general responsiveness: ok; EDT responsiveness: ok

 

 

8 comments

Hi Noah,

Does it hang on venv creation?

Try creating venv from the system terminal (outside of PyCharm).

0

I can create a venv outside of PyCharm just fine - I can run python3 -m venv test/venv and create one just as expected.

But even when I open that in PyCharm - the application hangs.

0

Please upload your renamed logs folder zipped from Help | Compress Logs and Show in... to https://uploads.services.jetbrains.com/ and let me know the name of that file.

0

logs-20190307-093224.zip

0

That let me open a previously created project with a venv, but I still can't create a new one or add an interpreter onto a project I'm working on.

0

Hmm, that't odd.

I have filed a performance problem to our issue tracker https://youtrack.jetbrains.com/issue/PY-34507, please follow it for future updates.

Our developer will look into your problem. Would be great if you could attach updated logs folder to the issue. You can change the visibility of the attachment in order to ensure the privacy.

0
 
I had the same issue as PyCharm was showing me the following Error:
 
Errno 2] No such file or directory: 'C:\\Program Files\\Python37\\lib\\venv\\scripts\\nt\\python_d.exe'

For me what fixed the issue was copying the python_d.exe and python_d.pdb from C:\Program Files\Python37 to C:\Program Files\Python37\Lib\venv\scripts\nt

hope this solves your problem ;)

0

Please sign in to leave a comment.