Anaconda for Pycharm on Linux

Answered

I am not able to access the anaconda in pycharm, first I tried to access two libraries and this error appeared. Libraries:

 

import pandas as pd

import numpy as np

erro:

Traceback (most recent call last):
File "/home/moises/Documentos/curso de python/Curso-Ciencia-de-Dados-master/Amostragem/amostragem1.py", line 1, in <module>
import pandas as pd
ModuleNotFoundError: No module named 'pandas'

And it's very strange because neither a new project nor it allows to create:

Has anyone ever experienced this?

NOTE: I use Python3.7

 

3 comments

Hi,

Have you tried to specify Conda executable path?

On Linux it is something similar to /home/<user>/anaconda3/bin/conda

0

@Sergey I already uninstalled the anaconda and the path was already specified. I already installed the modules through the command. But one mistake continues, of not finding the pandas and numpy modules.

specified module:

 

modules installed by the command:

pip3 install numpy && pip3 install pandas

I'm using Pycharm and Spyder so seeing is better, but neither is working. But when I run the import commands on the module through the terminal of my linux mint, it runs perfectly. Any suggestion?

 

 

0

Do you see these modules in File | Settings | Project | Project Interpreter? You probably installed them from the terminal to some system interpreter.

Why would you use pip in Conda environment instead of conda?

0

Please sign in to leave a comment.