Cannot uninstall PyCharm 2019.1

Answered

I installed PyCharm 2018 Prof but ran into the known issue "ImportError: DLL load failed: The specified module could not be found." I found on this forum that the an update to 2019 should solve the issue. So, I updated through Help/Check for updates. The update did not help and now I have the whole collection of issues

  • issue "ImportError: DLL load failed: The specified module could not be found." remains
  • workaround with creating PATH variable does not work, as I can only type in those fields but not copy-paste
  • PyCharm cannot connect to the console
  • Indexing takes a lot of time

I decided to uninstall and reinstall PyCharm, but I cannot. Both the standard Windows 7 uninstall procedure through Programs and Features and running Unistall.exe in JetBrains/PyCharm 2018.3.5/bin give the same pop-up window: "Uninstall hasn't detected folder of PyCharm installation. Probably uninstall.exe was moved from the installation folder". Also file Uninstall.exe has a different date then the rest of the folder. Any way to uninstall it cleanly?

I am using Anaconda3 with Python 3.7.

 

5 comments
Comment actions Permalink

I am experiencing the same issue.

How to perform a clean install?

1
Comment actions Permalink

I am experiencing the same issue too.

today  after I installed a UI and restarted pycharm,the pycharm didn't open.I tried to restart my PC,but it's no use.

so I wanted to uninstall pycharm and install it again

0
Comment actions Permalink

 The only way I found to be able to work is the following.

In my case the updated (2019) version was installed in the old 2018.3.5 directory. So, I downloaded the installer of PyCharm 2019.1. Installed it. It installed in directory PyCharm 2019.1. Copied uninstall.exe from the 2019 into the 2018.3.5/bin directory. Running it from that directory will uninstall the old PyCharm. Then I ran unistall.exe from 2019.1/bin directory also. So, I assume that all PyCharm installations are gone. Though I did not check registry for any remaining garbage.

After that I installed the earliest version 2018. You still need the workaround with PATH for every project, but at least it seems working.

4
Comment actions Permalink

Apparently, one needs a clean install of PyCharm 2019 to make it working properly. Update from the previous version did not work in my case. 

I uninstalled all versions of PyCharm and searched through the local and network disks to delete all the traces of pycharm or jetbrains. After that I installed the 2019 version from scratch and it seems to work. Indexing still takes some time, but for the other mentioned issues seem to be gone.

So, do not use Help/Search for Updates.

0
Comment actions Permalink

Hi all,
We were able to reproduce the issue https://youtrack.jetbrains.com/issue/PY-35047, please upvote and follow for updates.
It pops up after updating from the pop up message about new version available. It doesn't seem to happen when updating via Toolbox.

4

Please sign in to leave a comment.