PyCharm indexing about every minute or so

Hi.

 

Ever since upgradring from PyCharm 2018.<something> to 2019.1, PyCharm have started indexing about every minute or so. I've done the "File" > "Invalid Caches / Restart ", which didn't help. Looks like it's for the most part is processing this directory: c:\Users\<my-username>\AppData\Local\Programs\Python\Python37-32\Lib.

During indexing things such as autocompletion doesn't work, so it's pretty intrusive. 

Does anyone know what may be causing this, and what I can do to try an resolve this issue? 

5 comments
Comment actions Permalink

I'd say more than once a minute.  It's doing it every few seconds for me.

0
Comment actions Permalink

Hi Kenneth,

Can you please provide logs and CPU snapshot while the issue is reproduced?

Reporting performance problems – IDEs Support (IntelliJ Platform) | JetBrains

https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files

Please upload to our FTP and let us know the file name(s):

JetBrains - Uploads

0
Comment actions Permalink

Thanks for the advice. I've uploaded the files "idea-Kenneth-Holter-2019-04-03.log" and "PY-191.6183.50_keho_03.04.2019_09.48.50.zip". 

0
Comment actions Permalink

Thank you for the data, we will look into it to determine the cause, because the issue is affecting multiple users. 

For now, please try the following troubleshooting steps in order, and check if the issue is resolved after each step:

1. Do "File > Invalidate caches / restart"

2. Export your IDE settings, then delete PyCharm configuration directory, which can be located according to https://intellij-support.jetbrains.com/hc/en-us/articles/206544519

3. Delete ".idea" directory inside your project root, restart PyCharm, and re-open the project.

Kindly let us know if the issue was resolved, and after which step. 

0
Comment actions Permalink

I tried the first step, which didn't resolve the issue, but the second one seems to have done the trick. 

Thanks!

 

Btw, for some reason no longer can use the arrow keys in the switcher popup (Ctrl + Tab), but I'll report this as a separate issue. 

0

Please sign in to leave a comment.