Unable to click menu bar items in Android Studio plugin

Answered

Hi all,

I am new to Intellij plugin development and recently started working on a larger Intellij Android Studio plugin. I wanted to test how this plugin would handle multiple open Android Studio projects. However, I run into the issue in my Android Studio IDE where when I select "File>>New>>Project", nothing happens. In fact, whenever I select anything from the menu bar, nothing happens. 

 

What's interesting is that although I cannot select from the menu bar, I can use keyboard shortcuts as a work-around. For example, selecting "File>>Project Structure", nothing happens, but when I hit Cmd + ;, I can open the Project Structure dialog box. 

 

I believe this issue is specific to launching any Android Studio IDE from Intellij on a Mac (I am running High Sierra version 10.13.6). This is because other people involved in the project use Windows and do not seem to have this issue. Also, although the current project's Run Configuration is controlled through Intellij, I created a test Intellij plugin with gradle dependencies. This test Intellij plugin is the bare bones Intellij plugin created by selecting "Intellij Platform Plugin" in the Gradle tab when creating a new project. When I launched this Intellij plugin, I could manipulate the menu bar without any issues. But when I added 

alternativeIdePath '/Applications/Android Studio.app'

to my build.gradle of the test plugin and launched Android Studio, I could no longer the menu bar. So with two different types of build configurations, I have recreated the same issue. However, I have been unable to find someone who has posted something similar to this issue.

 

Currently, I am running Intellij 2018.3.6 and Android Studio 3.3.2 on MacOS High Sierra 10.13.6. In order to debug this issue, I have tried downloading multiple versions of Intellij and Android Studio. I am asking someone else on the project to download my versions of Intellij and Android Studio on a Windows desktop and running the project from there some time this week, but in general if I can debug this issue on my Mac that would make developing this project much easier, because I do not have easy access to a Windows computer.

 

If anyone has encountered this issue before or can point me in the right direction that would be great! I have attached a photos of me creating a simple Intellij plugin, as well as the build.gradle that I am using.

 

3 comments
Comment actions Permalink

What JDK is used to run Android Studio? Try using the same JDK as for the main IntelliJ IDEA instance (JetBrains Runtime). You can change it in the run/debug configuration JRE field.

See also https://intellij-support.jetbrains.com/hc/articles/206544879.

0
Comment actions Permalink

Hi Serge,

I have attached pictures of my Project Structure and Run/Debug Configuration from Intellij (dark mode), as well as the Run/Debug Configuration from my Android Studio launched from my Intellij plugin project. I believe they are all the same JDK.

 

 

0
Comment actions Permalink

That is an old Oracle JDK that has issues on Mac, you should use JetBrains Runtime instead.

https://bintray.com/jetbrains/intellij-jdk/

0

Please sign in to leave a comment.