Dynamic opacity in code

Answered

This might well be a general IntelliJ issue, but I use PyCharm so I'm posting it here. I guess I don't know the right terms to search for but there's a newish feature where code (Python or HTML) in the editor loses opacity or is slightly fainter except for code nearer the caret. It's driving me crazy and I can't figure out how to turn it off. I want it o be all full opacity/brightness all the time. When I switch to a new tab in the editor, it's all fully bright, but as soon as I click somewhere inside, some or all of the code looses brightness.

I have the "Highlight current scope" option off.

Is anyone else seeing this and is it possible to disable it?

Thanks,

David Lindsey

2 comments
Comment actions Permalink

Hi David,

Is it Mac OS?

There is a known problem https://youtrack.jetbrains.com/issue/IDEA-206887, please upvote and follow for updates.

See description for workarounds.

0
Comment actions Permalink

Thanks! I didn't realise it was a font-rendering issue. I assumed it sort of relevant-code-block-highlighting run amok.

0

Please sign in to leave a comment.