Command Line history using the UP key does not work inside Scrapy Shell

Answered

Brand new to Pycharm.  Using Version 2019.1.1 on Windows 10.

When in the Terminal, the UP key brings up the last command line entered.  Once I enter the Scrapy Shell, by typing

scrapy shell "http://quotes.toscrape.com/"

The UP key does not work and I have to type everything again and again.  Please help.

 

PyCharm 2019.1.1 (Professional Edition)
Build #PY-191.6605.12, built on April 3, 2019
Licensed to PyCharm Evaluator
Expiration date: May 15, 2019
JRE: 11.0.2+9-b159.34 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0

3 comments

Hi Steve,

Does it work on command line (outside of PyCharm)?
How did you install scrapy?

0

Thank you Sergey...

I am not sure how I did two tickets.  This has been solved.  I stumbled across the answer on StackOverflow.  You all must be really busy.

It did work everywhere else.  The problem was in the scrapy shell.  It just would not work...in fact, it would delete whatever was on the line.

I installed pyreadline and it works fine now.  Someone said it was a readline error so I tried it..

I installed scrapy inside of a project->file->settings->project whatever->found scrapy->installed scrapy

0

Glad that it works now. Thank you for letting me know!
I will note it for future reference.

0

Please sign in to leave a comment.