Toolbox install of IntelliJ 2019.1.1 causes Error launching IDEA cannot find VM options file

Answered

I have tried using the latest JetBrains Toolbox to first uninstall the so-called "manually installed" IntellIJ and then installing the lateset IntellIJ Ultimate (2019.1.1) *** THREE TIMES ***.   Each time, it fails with the same error when trying to launch:

Error launching IDEA

cannot find VM options file

Is this a bug in the JetBrains toolbox?

Is this a case of left-over "flotsome and jetsome" from previous "manual installs"?

Please advise on how to get IntellIJ properly installed via JetBrains Toolbox.

3 comments
Comment actions Permalink

Sorry for the inconvenience. Could you please go to IDE settings in Toolbox App (сlick the metal nut icon on the right-hand side of the IDE in Toolbox App) - Settings - Java Virtual Machine Options - Edit. Would the file be opened? Also please send Toolbox App logs (сlick the metal nut icon on the right-hand side of the Toolbox App) to toolbox-support at jetbrains.com.

0
Comment actions Permalink

Before I send the information you requested, I should let you know that I think this is a genuine bug in JetBrains Toolbox.  Hear me out as I explain the kludge-workaround that resolved (I hope permanently) the issue for me.

Solution:

Locate the Windows Start menu items associated with JetBrains Toolbox.

For me, the menu items are located at:

C:\Users\fpmor\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\JetBrains Toolbox\

which is generically also:

%APPDATA%\Microsoft\Windows\Start Menu\Programs\JetBrains Toolbox\


Locate the start menu item for IntelliJ, which for me is pointing to:

C:\Users\fpmor\AppData\Local\JetBrains\Toolbox\apps\IDEA-U\ch-0\191.6707.61\bin\idea64.exe

which is generically also:

%LOCALAPPDATA%\JetBrains\Toolbox\apps\IDEA-U\ch-0\191.6707.61\bin\idea64.exe


The error goes away when you change the completely blank (as installed by Toolbox) "Start in:" property of the IntelliJ start menu item to say:

%LOCALAPPDATA%\JetBrains\Toolbox\apps\IDEA-U\ch-0\191.6707.61\bin\

or

C:\Users\fpmor\AppData\Local\JetBrains\Toolbox\apps\IDEA-U\ch-0\191.6707.61\bin\

Do you still want me to send the logs or is the above enough evidence to convince you I'm correct in my assessment that there is a severe bug in JetBrains Toolbox, at least when it comes to installing IntelliJ 2019.1.1 on Windows 10 64-bit.

0
Comment actions Permalink

"Start in" should be empty, it doesn't affect IDE startup:

This shortcut works just fine. The issue must be elsewhere.

0

Please sign in to leave a comment.