There is No "Use soft wraps in editor" option in PyCharm 2019.1.1

Answered

I use PyCharm Professional 2019.1.1. 

As a way to apply soft-wrap by default, most explanations tell me to check "Use soft wraps in editor".

But there is No "Use soft wraps in editor" option in PyCharm 2019.1.1.

Am I missing something?

If you know that PyCharm 2019.1.1 has changed to a new method, please give me the answer.

 

 

9 comments

If I correctly understand, you would to wrap your code as you type?

If yes, it can be found under Preferences | Editor | Code Style | Python --> Wrapping and Braces --> Wrap on typing

0

What I want is soft-wrap by default when opening files.

And I am wondering why the checkbox (placed in File | Settings | Editor | General --> Use soft wraps in editor) disappeared.

Your comment is good but it does not change the code. Thank you.

0

I think it was moved to a separate group of settings

Have you tried it yet?

0

Yes I already tried it as my screen shot.

I check the "soft-wrap files" but it does not change the default (not wrapped).

 

0

Could you share some example? Screenshot will do.

From what I can see, it adds the soft wraps once I apply the settings.

0

This is screenshot of my PyCharm.

The 49, 51 lines are not wrapped.

I already check the box and restart the PyCharm, but no work.

The shortcut for soft-wrap is working, but it does not wrap my code by default.

0

Hmmm, that's odd.

Do you use custom plugins?

If yes, please disable them all and see if it helps.

By the way, does it work in a new test project?

0

No, I don't use any plugins.

And a new test project also does not wrap long line.

I guess I'll probably have to use the hotkey and wait for additional updates.

Thank you for your advice and suggestions.

0

We could investigate a bit further if you like.

If yes, please upload your renamed logs folder zipped from Help | Compress Logs and Show in... to https://uploads.services.jetbrains.com/ and let me know the name of the file so I can find it.

0

Please sign in to leave a comment.