Exclude part of intellij-openapi dependencies

Answered

Hi!

Can some of the intellij-community's dependencies be excluded?
E.g. I need to use sqlite-jdbc 3.27.2 in my plugin, but it's get overwritten by dependency of IdeaIC:2018.3 which is 3.21 version.

What should be changed in my build.gradle file? 

My intellij section is:

intellij {
version '2018.3'
plugins 'git4idea'
pluginName 'yet-another-plugin'
downloadSources true
}

Thanks!

3 comments
Comment actions Permalink

Did you try adding

 compile group: 'org.xerial', name: 'sqlite-jdbc', version: '3.27.2'

to dependencies section of your build.gradle?

0
Comment actions Permalink

Hi Yann!

Sure, it's added even with `force` flag: 

compileClasspath ('org.xerial:sqlite-jdbc:3.27.2'){
force = true
}

If `compileClasspath` is changed to `compile` group, driver couldn't be found in classpath after running plugin from IDE with task `runIde`.

However, I still get driver from IdeaIC in runtime.

0
Comment actions Permalink

So, OK, this is solved somewhy when I rearranged my dependencies and placed sqlite-jdbc as a last entry. I don't know why, but it helped. \shrug

0

Please sign in to leave a comment.