Mardown plugin doesn't show preview

Hey there,

as described above my WebStorm IDE doesn't show up the preview tab for markdown files anymore. This happens with any .md file. A current example, as provided below might look like this.

idea.log

README.md

16 comments
Comment actions Permalink

Does it happen always? is the issue specific to certain .md file? Please can you recreate the issue and provide your idea.log (https://intellij-support.jetbrains.com/hc/en-usa/articles/207241085-Locating-IDE-log-files) and .md file that shows it up?

0
Comment actions Permalink

Hi Elena, I've just updated my original post. Hope that's fine as well. If I should still create a new issue, let me know. Just wanted to prevent unnecessary spamming.

0
Comment actions Permalink

I don't have problems previewing your file... I can see some errors from Markdown Navigator plugin in the log - does the issue persist after disabling it?

0
Comment actions Permalink

The issue persists when re-enabling the plugin as well as restarting the IDE.

0
Comment actions Permalink

Similar issue is tracked at https://youtrack.jetbrains.com/issue/RUBY-23619... Looks like a JavaFX problem specific to certain environment

0
Comment actions Permalink

It's actually not that similair, because I don't even have the possibility to click on a preview button on the right corner (as it usually was). It basically doesn't exist at all. See attached image below.

 

0
Comment actions Permalink

Is Markdown Navigator plugin enabled? if yes, please disable it and restart the IDE

0
Comment actions Permalink

I've installed both plugins. Markdown Navigator as well as Markdown Support (by JetBrains). Yet none of both seem to work. I've disabled both. Restartet. Enabled Md Navigator -> Didn't work. So I disabled it, restarted again and enabled Md Support afterwards. Still nothing works.

0
Comment actions Permalink

Could you please attach idea.log after disabling all the 3rd party plugins? (.ignore (3.0.0.182), ANSI Highlighter (1.2.4), Angular 2 TypeScript Live Templates (2.0.0), Angular Templates (1.1.3), Awesome Console (0.1337.6), Bootstrap 3 (4.1.1), Bootstrap 4, Font awesome 4, Font Awesome 5 Free & Pro live templates/snippets (6.1.0), CPU Usage Indicator (1.8), CamelCase (2.1.0), Dash (3.3), Git Scope (2.1.1), GitToolBox (191.1.2), HighlightBracketPair (1.1.2), Import Cost (1.0.7.1), JSON Sorter (1.0.0-beta.3.2), JSON Viewer (0.3), Markdown Navigator (2.8.4), Material Theme UI (3.9.2), Mongo Plugin (0.12.0), NativeScript (0.14.0), Quokka (1.0.157), Rainbow Brackets (5.18), SonarLint (4.0.2.3009), String Manipulation (6.1.143.000.0), Toml (0.2.0.22))

0
Comment actions Permalink

Excuse my late response. Due to vacation I didn't have the time to answer.

However, here's my new idea.log. Markdown is still not working.

0
Comment actions Permalink

Sadly I didn't get enough help in here. However after playing around with different file endings (md, mkd, markdown) I've been able to solve the problem on my own. The problem was pretty simple. I just had the file name README.md declared as a text file within the IDEs file types.

That said, I just had to remove README.md from Settings | File Types | Text files.

This one just helped out a lot: source

0
Comment actions Permalink

sometime is because

java.lang.NoClassDefFoundError: Could not initialize class com.sun.webkit.WebPage
at javafx.scene.web.WebEngine.<init>(WebEngine.java:881)
at javafx.scene.web.WebEngine.<init>(WebEngine.java:868)
at javafx.scene.web.WebView.<init>(WebView.java:273)
at com.intellij.ui.javafx.JavaFxHtmlPanel.lambda$null$4(JavaFxHtmlPanel.java:54)
at com.sun.javafx.application.PlatformImpl.lambda$null$5(PlatformImpl.java:295)
at java.security.AccessController.doPrivileged(Native Method)
at com.sun.javafx.application.PlatformImpl.lambda$runLater$6(PlatformImpl.java:294)
at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:95)
at com.sun.glass.ui.gtk.GtkApplication._runLoop(Native Method)
at com.sun.glass.ui.gtk.GtkApplication.lambda$null$10(GtkApplication.java:245)
at java.lang.Thread.run(Thread.java:748)

0
Comment actions Permalink

I'm experiencing the same issue now.  This has worked for a long time in the same project, but this week it's no longer showing the preview.  Two significant things have happened this week, which might be contributing. 

1) Upgraded from 2019.2 to 2019.3

2) Upgraded Java from Oracle JDK 8 to OpenJDK 11 

0
Comment actions Permalink

Mar10, Michael Faith could you please provide more details? Please share idea.log (Help - Show log in) and also a project sample for reproduce. If you want you can submit an issue on the tracker and attach the files with restricted visibility: https://youtrack.jetbrains.com/issues/IDEA?q=Subsystem:%20%7BLang.%20Markdown%7D%20

0
Comment actions Permalink

Thanks for the reply.  My issue has been resolved.  I logged a support ticket after I remembered that I could do that, haha.  Turns out the OpenJDK I'm using doesn't have JavaFX.  So I switched to the bundled Jetbrains JDK, by removing the IDEA_JDK_64 environment variable, and it started working again.

0
Comment actions Permalink

Michael Faith, good to know that, thank you for the update!

0

Please sign in to leave a comment.