5 comments
Comment actions Permalink

Hi Alexandre,

Have you tried to install it from the system terminal (outside of PyCharm) using the same interpreter? Does it also fail to install?

0
Comment actions Permalink

I use this command in my cmd in the repository of scapy : python setup.py install

And after, i have this :

And if i use some commands in the python interpreter, it works :

But the same commands in PyCharm doesn't work :

Sorry for my english, im french

0
Comment actions Permalink

Do you use the same interpreter in both cases?

To check which interpreter you are using in the command line run where python

If the interpreter is the same as in PyCharm, check that the package is shown among installed ones in File | Settings | Project | Project Interpreter

In case it is there, do File | Invalidate Caches/Restart...

By the way, have you tried to install the package with PyCharm's UI?

0
Comment actions Permalink

This is the same interpreter :/

And this is all package i use :

I tried to do "File -> Invalidate Caches/Restart" and i have the same problem..

0
Comment actions Permalink

I can reproduce this problem, but it is also reproducible in a command line. Try running the same command as PyCharm does (the first line in the console output) and it will fail.
These are just notes, which are not related to the problem directly, but it worth mentioning:

1) from scapy.all import all doesn't seem to be correct import

2) You shouldn't use the filename the same as the package you are importing. Choose a different less generic name for the file.

0

Please sign in to leave a comment.