Can't activate by account, due to the proxy problem.

Answered

I use the student account download the pycharm and want to activate the account. 

But it always mention me my host may be behind a proxy even when I don't use any proxy. 

30 comments
Comment actions Permalink

Have you tried to temporary disable antivirus/firewall?

0
Comment actions Permalink

Yeah, it also doesn't works. And I tried free trail yesterday, it just showed connection refused now.

0
Comment actions Permalink

Something is blocking the connection. We don't have other such issues reported recently so this isn't on our side.

If you cannot solve this network issue, you're welcome to use an offline activation code which you can download from https://account.jetbrains.com/licenses

0
Comment actions Permalink

I'm willing to use the offline activation code but I don't find the download link.

I just got my license ID and my license is for educational use only.

0
Comment actions Permalink

Don't you have this option? It's right below your license ID

0
Comment actions Permalink

No, maybe the educational use only license doesn't have this option.

0
Comment actions Permalink

I checked it and you are right, the student licenses don't have this option anymore. Sorry for the confusion.

0
Comment actions Permalink

So how can I solve it...Do you have other suggestions?

0
Comment actions Permalink

Sorry, there are no other options for offline activation. You should fix the network problem to let PyCharm connect to the server.

0
Comment actions Permalink

But I don't know where is the network problem, everything is ok...

0
Comment actions Permalink

Well have you maybe in your /etc/hosts file an entry like:

0.0.0.0 account.jetbrains.com

that for sure will cause the same problem as mentioned.

2
Comment actions Permalink

@Juliette Thank you very much. It's work now~

0
Comment actions Permalink

I have exactly the same issue. I also have educational licence, I'm working on windows. I tried to disable th firewall and also checked the C:\Windows\System32\drivers\etc\hosts file but neither of them resolved he issue.

Can you please help somehow, I don't have any idea how to proceed. 

0
Comment actions Permalink

@Udvzoli

Try in your system terminal:

> telnet account.jetbrains.com 443

(you may need to install the telnet utility if you don't have it). You should get a blank screen if connection is established

Also, does https://account.jetbrains.com/ open in your browser?

If that's not working, you're probably behind a proxy and need your proxy credentials to proceed.

0
Comment actions Permalink

Thanks Andrey for the reply!
Both worked what you have suggested. I can open https://account.jetbrains.com/ in my browser and the telnet command returns a blank screen as you can see on the picture attached.

Do you have any other suggestion what I could try, or how I could activate my licence?

Thanks

0
Comment actions Permalink

@Udvzoli, you say you can open https://account.jetbrains.com, but is that showing the login page, or is that not showing anything either like Telnet.

The IP(4) adress I have on Jetbrains is: 63.32.207.43. You can check also here: https://ipinfo.info/html/ip_checker.php and use the jetbrains account url.

If you are getting something else with your local ping you must check the hosts file. Please let me know the result.

0
Comment actions Permalink

Hi @Juliette, the https://account.jetbrains.com is not blank it shows my personal account with my licences listed. 
However if I check the IP for the same site I get different results, I attached in a picture.
I have already checked the file located here: C:\Windows\System32\drivers\etc\hosts and there is nothing like jetbrains.

If you know the problem and you have any other tips I am happy to follow them.

Thanks

0
Comment actions Permalink

Some details I would like to add, maybe this will help.
So I have been using the Community Edition for a year and I don't have any problems with downloading plugins, using remote repositories etc. 
I tried also the Professional version in trial mode and there I can't download any plugins or check for updates because it says there is some problem with my internet connection. This is on the same computer and same network.

Do you know how it could happen that everything is fine with the Community Edition but the Professional one can't connect to the internet? It was complaining about bad proxy settings at th activation but why is it assuming that I am behind a proxy?

Thanks

0
Comment actions Permalink

@Udvzoli

Firewalls have the ability to block connections on per-process basis, this might explain why one program works and other doesn't.

Please try again:

> ping account.jetbrains.com

What IP is shown?

0
Comment actions Permalink

Hi,

Thank you for your comment. I tried to disable my firewall before but it didn't help.

The IP shown is this: 54.246.146.192.

0
Comment actions Permalink

@Udvzoli

I think we should deploy heavy artillery on this one. Can you capture TCP dump while attempting to activate PyCharm?

I'm sorry I won't go into the details on how to do that, but there's plenty of guides available if you google. On Windows you can use WireShark, on Linux/Mac you can use "tcpdump" utility.

0
Comment actions Permalink

Hi Andrey,

I captured my dcp dump as you suggested I got a pcapng if it is ok for you. Could you please provide me with your contact information, so I can send you the file?

Thanks

0
Comment actions Permalink

You can upload here and let me know the file name: https://uploads.services.jetbrains.com/

0
Comment actions Permalink

Hi, I uploaded the file, it's name is: pycharm_udvzoli.pcapng.

THanks you very much for looking into it!

0
Comment actions Permalink

I am having the same issue as Udvzoli. Cant register to my student account due to proxy server. Can anybody help?

0
Comment actions Permalink

I had this issue today and I found a way to fix it :

Instead of linking your account in this window, When pycharm ask you if you want to start it for 30 min click on okay and then go to file > settings > system settings > HTTP proxy and click on auto-detect proxy settings. After that you want to go to help > register, enter your credentials and click on activate.

I hope this helps.

7
Comment actions Permalink

Thanks Vincent Archambault 1 Finally this helped me. I don't know why Jetbrains make manual configuration as default, that was really annoying. This issue wasted my 2 hours and finally get this solution.

0
Comment actions Permalink

I tried all of the non-ridiculous things suggested in this thread and then I realized, after reading this support post that I already knew the answer. Prior to the rule change regarding Educational License usage, I used the paste the key method and used the product. When I started using PyCharm to learn the Django framework, I was having issues installing libraries within the Project Settings. Like it says in the linked post, and elsewhere, some proxies are not auto-detectable and inCert an SSL CA Certificate (see what I did there). Using the keytool, I just inserted this "invisible" proxy's cert in the keystore used by Pycharm.

Here is little a joke I tell, "The password is 'changeit', but DON'T". This works for many jetbrains products, and unlike the linked post suggests, you don't have to talk to the NetOps guy.

keytool -import -alias key_alias -file "path/to/proxy_cert.der" -keystore "C:\Program Files\JetBrains\PyCharm 2019.3.2\jbr\lib\security\cacerts"

I created that screenshot before I found the code option. Redundancy is for copy/pasters.

This was my first time using this method with PyCharm, but I would imagine you might get a "Conflicts found in the installation area" error, so be smart MAKE A BACKUP OF cacerts FIRST! If you were not smart, here is the Google's Android Studio solution (Man, I really wish the guy who asked that question would mark mine as the correct answer; feel free to tell him :) to that error, which I imagine will also work.

1
Comment actions Permalink

I had the same issue with educational use only licence. I tried Vincent Archambault 1 solution. It works.

Just to add-on, after selecting auto-detect proxy settings, click Check connection and type: http://account.jetbrains.com

After that go to Help -> Register.

 

This worked for me!

0

Please sign in to leave a comment.