Key map for "group by packages" couldn't be turned off in Find panel

Answered

I remapped my key-bindings and everything worked fine except one little twinge when navigating inside the Find panel (Alt+3) with "Ctrl+P" to move up the selection. I use "Ctrl+P" to move up everywhere (courtesy of Emacs key-bindings) and removed all key-bindings for "Group by packages", but when I try to move up it's still invoked instead of moving up. "Ctrl-F" (forward) also has the same problem and is overridden by "Merge usages from the same line". Moving down (Ctrl+N) and backward (Ctrl+B) worked fine though. I wonder if it's because the key-bindings of the panels aren't managed in the keymap settings. System info: Fedora 29, Intellij IDEA Ultimate 2019.1.2.

0
5 comments

Hello Ivan,

We have related issue on YouTrack: https://youtrack.jetbrains.com/issue/IDEA-201811

Please follow it for updates.

0

I am having the same issue with IntelliJ IDEA version 2020.1.  I have "ctrl-alt-p" mapped to Navigate->previous occurrence.  This issue is especially noticeable now when you do a search for usages ALT-F7 and there is only one result to show.  When there is only one result to show, IntelliJ wants to invoke "group by packages" in the find window when I press "ctrl-alt-p".  Apparently this keymap for "group by packages" cannot be disabled.

What is interesting is that if the ALT-F7 keypress finds multiple usages then "ctrl-alt-p" behaves differently.  It will not invoke the "group by packages", but rather the action I want which is "show previous occurrence".  This works great since the cursor is placed directly in the editor of the occurrence.  If there is more than one occurrence to show in the window, then the "group by packages" gets invoked and there is no keystroke to take you to it.  The ESC key does not return the cursor to an editable location, and neither "ctrl-alt-p" nor "ctrl-alt-n" will either.

Is there a way to disable or change the ctrl-alt-p key mapping in the find window?

Maybe this is a separate issue than the one referenced above?

0
Avatar
Arseniy Nisnevich

> Is there a way to disable or change the ctrl-alt-p key mapping in the find window

Go to Settings | Keymap, press "Find actions by shortcut" loupe, press ctrl-alt-p and change the shortcut for "Packages".

0

Yes, I have done that.  The only ctrl-alt-p keyboard shortcut that now shows in this window is mapped to the action I want which is Navigate->Previous Occurrence.    Unfortunately, this trick does not show any other keyboard mappings for ctrl-alt-p.  Yet, the find window still shows ctrl-alt-p mapped to Group by packages.  It appears to me that this ctrl-alt-p keystroke is not mappable by settings->keymap 

0
Avatar
Arseniy Nisnevich

Thank you for clarifying. Turns out this is a known problem: https://youtrack.jetbrains.com/issue/IDEA-236527

Please, vote and follow for updates. If you aren't familiar with YouTrack, see this instruction.

0

Please sign in to leave a comment.