Can't edit anything for ~10 seconds after running tests with keyboard shortcut

Completed

I've googled around and didn't find anything with a similar issue, hence I'm posting here. 

If I click either the 'Rerun' action or even the 'Run' action by clicking or through the action browser, the editor doesn't hang.
But if I trigger either one of those with the assigned keyboard shortcut, I can't edit any file (even though having focus of course) for some 10 seconds or so. 
After those 10 seconds or so I can edit again without any issue at all.
Oh, and this isn't because there is some PyCharm processing going on, since I can click around the files without any problem, just can't edit none of it!

This is a rather annoying problem and really looking forward for any idea you might have on on to fix it.

Thanks in advance,
Nuno

0
2 comments

Hi Nuno,

I can't reproduce it on my side.

Do you use some custom plugins?

What is your PyCharm version and OS?

0

Ok this is weird.. I just checked the plugins I have installed (One Dark Theme and Vue.js) and after updating them and it seems like it fixed it.

I find it hard to believe it had anything to do with those, but at the moment I cannot reproduce myself the issue I was having, so I guess you can mark it as solved.

Hope it won't come back though.

In any case, thanks for pitching in.

0

Please sign in to leave a comment.