How activate virtualenv from pycharm terminal

Answered

My project interpreter is setup to use a virtual environment, which was created by pycharm while it was creating the the project.

While I used to open project, pycharm used to provide me the terminal with virtual-environment is activated.

But I executed "deactivate" command from terminal provided by pycharm. 

How can I activate the virtual-env from the terminal ?

 

3 comments
Comment actions Permalink

If Activate virtualenv is checked under Settings/Preferences | Tools | Terminal, then it should be enough to just close the terminal tab and open a new one.

0
Comment actions Permalink

I am sure I have done it. But it still doesn't work. I still have to activate the environment myself. How should I do it?

0
Comment actions Permalink

Same trouble at Windows 10

0

Please sign in to leave a comment.