[Rider] Source Code Pro font disappeared after upgrading

Answered
JetBrains Rider 2019.1.3
Build #RD-191.7141.460, built on July 10, 2019
Subscription is active until July 29, 2019
JRE: 1.8.0_212-release-1586-b4 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0
 
 
After Rider is upgraded to 2019.1.3,  I can't find "Source Code Pro" in the font list anymore.
 
6 comments
Comment actions Permalink

Does it help if you reinstall the TTF files for the font from https://github.com/adobe-fonts/source-code-pro ?

0
Comment actions Permalink

Yes, I download these files and install them manually, and finally can use it again.

Just a bit curious about why this happened.

0
Comment actions Permalink

JBR8 didn't include the fonts out of the box, but it should be fixed for the next release: https://youtrack.jetbrains.com/issue/JBR-1566.

0
Comment actions Permalink

Got it, thank you. ;)

0
Comment actions Permalink

After I installed fonts manually, I see this for commented code:

css code in html file :

html comment:

script tag

 

If not commented looks fine. I guess there is some another font used for comments. How can I fix this behavior? 

WebStorm 2019.2
Build #WS-192.5728.87, built on July 22, 2019
Runtime version: 1.8.0_191-b12 amd64
VM: Java HotSpot(TM) 64-Bit Server VM by Oracle Corporation
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 986M
Cores: 4
Registry:
Non-Bundled Plugins: String Manipulation, com.intellij.lang.jsgraphql

0
Comment actions Permalink

Try disabling italic font for the comments, it looks like italic version of the TTF file you've installed is broken.

0

Please sign in to leave a comment.