Prevent parallel reload of CMake projects

Answered

Hello all

My CMakeLists.txt runs a git command when build files are generated. I have a debug and a release configuration defined in CLion. Now when I change something that triggers a cmake project reload both configurations are triggered at the same time. This sometimes causes odd results for the git command (or one of them randomly failing).

Is there a way to prevent the parallel reload and have them reload one by one?

BR
Yanick

3 comments
Comment actions Permalink

Hi!

Unfortunately, for now it's not possible to disable Cmake profiles.

Feel free to comment or upvote https://youtrack.jetbrains.com/issue/CPP-12870. See https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications if you are not familiar with YouTrack.

 

 

0
Comment actions Permalink

Hi I'm having the same problem, the linked issue is not really relevant for this. I don't want to disable profiles, only that the are loaded *one after another*, i.e. not in parallel. Is this possible?

0
Comment actions Permalink

@Rbarton thanks for the comment! I've created another feature request https://youtrack.jetbrains.com/issue/CPP-20496. Feel free to comment or upvote.

1

Please sign in to leave a comment.