Idea overrides java version for terminal

Answered

Windows 10.

JAVA_HOME environment is set to 1.8_221

Project SDK is set to java version 1.8

Open terminal in Idea 2019.1 and check java version: it will be similar to JAVA_HOME and version of Java used in project

Open terminal in Idea 2019.2 and check java version: terminal will use bundled java version instead of JAVA_HOME and version of Java used in project

Probably you can provide workaround to disable this behavior?
It is critical for us to use the same java version in terminal as it set for project

3 comments
Comment actions Permalink

Have you tried to change Environment variables under **Preferences | Tools | Terminal**?

0
Comment actions Permalink

I'm also having this issue. It's a bit frustrating for me that java 8 can't run in this built-in terminal.

I tried to change the settings you suggested but those environment variables are immutable.

0
Comment actions Permalink

Here is a related issue on YouTrack:

https://youtrack.jetbrains.com/issue/IDEA-218032

As it can be seen here, the issue will be fixed in IntelliJ IDEA 2019.2.1

0

Please sign in to leave a comment.