indentation of multiline (string) parameters


^ This is how my version of PhpStorm 'renders' indented multiline parameter-strings. It seems to force some extra 'fake' indentation, and it indents the indentation-helper-line a bit too. It drives me nuts :-)

When pasting above code in Notepad, it looks like this:


Which is pretty much exactly the way I want it.

Does anyone know how I can configure PhpStorm to stop doing this..?

5 comments
Comment actions Permalink

You can use Paste Simple (Ctrl+Alt+Shift+V) to make PhpStorm pasting the sample without reformatting it.
Apart from that, it makes sense to take a look at the continuation indent value at Settings | Editor | Code Style | PHP.

0
Comment actions Permalink

Thanks for your reponse. It doesn't solve the problem.

0
Comment actions Permalink

Maybe it's just an issue of representation then? Please enable Settings | Editor | General | Appearance | Show whitespaces and check what is the actual indent there.
Apart from that, please check if disabling smart tab at Settings | Editor | Code Style | PHP helps. If you are using tabs, of course.

0
Comment actions Permalink

Thanks for your reply and sorry for the slow response.


This is how it looks with 'show whitespaces' enabled:

Finally i went over my configuration looking for things I've changed from the defaults, and then I stumbled upon the cause of the problem: a custom font (Monaco). Switching to Droid Sans Mono immediately gave this result:

 









 

0
Comment actions Permalink

Note: the same happens with the fonts Lucida Console and PT Mono

0

Please sign in to leave a comment.