`application.properties` in Spring Boot Project not working


I have some spring boot projects working correctly in IDEA before. However, today i meet some problems when i'm trying to create a new spring boot project via File->New->Project->Spring Initializr.
The contents in `application.properties` seems to be ignored by IDEA 2019.2.2. I have tried to set `server.port=8081`, `debug=true` or the datasource, they didn't work.

However, if i try to use `gradle bootRun`, everything seems to be well.

I have tried to open the project by IDEA 2019.1.4, they worked correctly. Difference between their contents in the terminal were:
2019.1.4 and 2019.2.2.

I have tried to invalid caches and restart, use another computer with a new project in IDEA 2019.2.2 (Windows 10) and got the same error. But IDEA 2019.2.2 on Ubuntu seem to work fine.

I'm using Windows 10, IDEA 2019.2.2, JDK 1.8.0_221.

Plz... What's wrong with this? What extra information should i provide? Is there any problem with my environment? Thanks a lot...


Please sign in to leave a comment.