Can't specify the path for pycharm_helpers when adding a remote interpreter

Answered

As you can see in the first image, there is no option for me to specify the pycharm_helpers path manually. I think what PyCharm will do is to automatically specify the path by itself and upload helper files to that path. It might be fine for most cases, but the thing is, my server only serves as a login node, in another word, there is no space under /home/ directory, which is probably where PyCharm is gonna put its helpers, as a result, you can see from the second image that it fails to create python sdk because there is no space for those helpers files. I have resolved this issue by editing a previous remote interpreter configuration I have (because the previous configuration has an option for helper files path), but this is really not an elegant way. I do believe there should be a way for us to specify the path for helpers files explicitly. Automation is convenient but sometimes can also be problematic and leads to more unnecessary troubles!

4 comments
Comment actions Permalink

Hi,

Unfortunately, it's not possible to specify the helpers path during remote interpreter configuration.

Please feel free to submit a feature request/usability problem about it to our issue tracker using the link https://youtrack.jetbrains.com/issues/PY

0
Comment actions Permalink

Thanks for the response. So do you have any ideas on how to solve the problem I mentioned (i.e., the default helpers path doesn't have enough space)? If I didn't happen to have a previous configuration for another remote interpreter, it seems to me there would be no way for me to configure my remote interpreter. 

0
Comment actions Permalink

Unfortunately, it's not configurable :(

Maybe it is possible to work around it with symlinks, but I'm not sure.

0
Comment actions Permalink

This really sounds like a bad design :(

0

Please sign in to leave a comment.