Problem creating conda environment

Hi.

 

I am trying to setup conda environment in pycharm, but it gets stuck at "creating conda environment" after pressing "create". Any idea what is the reason behind that ?

 

2
7 comments

Could you try creating a conda environment from the system command prompt and see if it hangs as well? Make sure to use the same conda executable.

If it's not reproducible from cmd:

1) Provide us with versions of Conda and Anaconda/Miniconda.

2) Send a screenshot of the interpreter configuration when trying to configure it in PyCharm during project creation so that I can see which conda executable is being used.

3) Add the following line to Help | Debug Log Settings (including #), reproduce the problem and provide idea.log file from Help | Show Log in...:


#com.intellij.execution.configurations

You can upload idea.log file to our FTP server zipped https://uploads.services.jetbrains.com/, but please let me know its name.

0

Same (or similar) problem here.

(Froze at this stage, waited for a half hour anyway just in case, but no movement. It IS spinning the CPU though.)

Conda creates environments from the command line no problem.

Conda: 4.7.10

Anaconda command line client: 1.7.2

Everything was defaults:

Where is "Help | Debug Log Settings"?

Tried again and this time it froze on "$ conda update -n base -c defaults conda"

Ran that from the command line and it worked fine.

Both the update and the environment creation _do_ prompt the user to continue though. Is it getting stuck on that?

Tried again and now it's back to getting stuck on vs2015_runtime-14.16 (Conda is now 4.7.12)

Can't get to the Help menu since Creating Conda Environment window is modal.

0

I was having the same issue, solved with

conda update --all
6

Same issue here. When creating a new enviromet with anaconda it got stuck under VS2015_runtime. Then as gpires recommended I did

conda update --all

and this fixed my issue

3

This command seriously worked man

conda update --all

steps -> first close every application related to python, then open anaconda prompt and then just type above command.

Try it, Happy Coding :)

0

I agree with all the above - had the same issue, conda update all solved it.

Thanks gspires!

0

I agree with all the above - had the same issue, conda update all solved it.

Thanks gspires! :)

0

Please sign in to leave a comment.