Datagrip x BigQuery - Datagrip won't read the schema

Hey there

Getting a weird error for two days where Datagrip can't read the schema structure in BigQuery and as a result do not show any dataset or tables. Autocomplete is also gone as result.

Querying the database and connecting is still working.

The error code retrieve when trying to refresh the schema is:

Y000][100092] [Simba][BigQueryJDBCDriver](100092) Project operations error. Message: null
and 3 duplicate reports (1 m 43 s 917 ms)

I am using Datagrip 2019.2.6 on MacOS. Database is BigQuery and I'm using the Simba driver.

Thanks in advance for the assistance!



Same problem for me, could you give us some suggestion?



T Ducrot , Albert Caramia

Could you e-mail me full IDE & SQL logs?

Also, it'll helpful to get JDBC driver version.


Hi Vasily,

thanks for your reply.

IDE: DataGrip (build #DB-192.7142.42, 30 Oct 2019 16:35)

jdbc: last simba driver (com.simba.googlebigquery.jdbc42.Driver)

I followed this tutorial:

I think I solved the issue: I modified the schema pattern in the schema tab (properties on connection).

When I select only the current database/dataset (schema pattern: databasename:datasetname,) , it is possible to introspect the schema and Autocomplete starts working.


Hi Vasily,

I am using:

DataGrip 2019.2.6
Build #DB-192.7142.42, built on October 30, 2019
Licensed to Wargaming Group Limited / Thomas Ducrot
Subscription is active until January 27, 2020
Runtime version: 11.0.4+10-b304.77 x86_64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
macOS 10.14.6
GC: ParNew, ConcurrentMarkSweep
Memory: 1981M
Cores: 8
Non-Bundled Plugins: org.jetbrains.plugins.terminal

Using the simba driver: SimbaJDBCDriverforGoogleBigQuery42_1.2.2.1004

Uploaded the logs here:

I could reproduce the same behavior using Pycharm Pro Version, and I had a similar error using different version of Simba BQ drivers.

Hope that helps!



T Ducrot,

It looks like JDBC driver issue. Could you apply schema pattern as it was mentioned by Albert Caramia in your data source settings?


Hi Vasily,

I double checked the setting but the database schema settings is already set up like this.

I am still getting the same error when trying to refresh the schema.

[HY000][100092] [Simba][BigQueryJDBCDriver](100092) Project operations error. Message: null
and 3 duplicate reports (1 m 28 s 670 ms)


Could you change @:@  according to pattern: databasename:datasetname.

In your case it would be wg-mobile-hq:<your-dataset-name>



By the way you can expand list, e.g



It seems that Datagrip / the driver can't detect the schemas/datasets in BQ.

Specifying explicitly a single schema/dataset also trigger the same error...


You're right, it's JDBC driver issue.

Do you know data set you need to work with to specify in schema pattern?


I'm having the same issue, and specifying one specific schema in the schema pattern isn't solving it.


There's a comment in DBE-2497 describing how to connect using OAuth values from the Google Cloud SDK rather than a service account private key file, and it turns out doing that avoids this error when doing introspection.


I have same problem. Tools cannot showing schema. Is the issue solved?

Yuriy Vinogradov

Yes it works fine in DataGrip v.2020.1 with JDBC driver v.


Thanks for the reply, Yuriy.

But on my case, it is only showing the one database although the project has two database.

Could you please confirm that it is possible to show up multiple database in the project?

Yuriy Vinogradov

It's not database, it is "data set" in terms of BigQuery, yes, I just checked, I can see multiple data sets with tables in one project. Could you please click the 'N of N' link (or there is just a number) next to your project name and select "All schemas" and hit refresh button?


I found the solution from datasource property. "AdditionalProjects" setting helped me to see all the schema's in the project.



I have the same problem as T Ducrot with PyCharm.

I'm able to query the tables in BQ but the schema introspection always shows a timeout error:

[HY000][100092] [Simba][BigQueryJDBCDriver](100092) Project operations error. Message: Read timed out
and 3 duplicate reports (19 m 0 s 994 ms)

It happens with @:@  and with a specific project:dataset

Can someone help?



Please sign in to leave a comment.