Autocomplete SQL join clause without table name

Answered

Hello,

I cannot remove the table name from the SLQ autocompletion join clause.

In exemple two linked table, "son_table" has a foreign key with "father_table":

CREATE TABLE father_table (fth_id     integer PRIMARY KEY);
CREATE TABLE son_table (snt_fth_id integer REFERENCES father_table(fth_id));

And the autocompletion suggested:

 

The table name is included on the join clause and I cannot remove it from the autocomplet suggestion.

I tried the following configurations without success:

1) In Settings / Editor / General / Code Completion:

 

2) In Settings / Editor / General / Smart Keys:

 

Is there any other configuration to remove table name from autocompletion, please ?

 

Expected:

But have:

 

BR,

Laurent

1 comment
Comment actions Permalink

Thank you for feedback, I created an issue based on your description https://youtrack.jetbrains.com/issue/DBE-9708

0

Please sign in to leave a comment.