error installing cython extension

Hi, while debugging python script I get popup with information to install cython extensions. I click "install" but it ends with error:

```

Non-zero exit code (1):
/home/kossak/.asdf/installs/python/miniconda3-4.3.30/compiler_compat/ld: /home/kossak/.PyCharm2019.3/system/cythonExtensions/build/_pydevd_bundle/pydevd_cython.o: unable to initialize decompress status for section .debug_info
/home/kossak/.asdf/installs/python/miniconda3-4.3.30/compiler_compat/ld: /home/kossak/.PyCharm2019.3/system/cythonExtensions/build/_pydevd_bundle/pydevd_cython.o: unable to initialize decompress status for section .debug_info
/home/kossak/.asdf/installs/python/miniconda3-4.3.30/compiler_compat/ld: /home/kossak/.PyCharm2019.3/system/cythonExtensions/build/_pydevd_bundle/pydevd_cython.o: unable to initialize decompress status for section .debug_info
/home/kossak/.asdf/installs/python/miniconda3-4.3.30/compiler_compat/ld: /home/kossak/.PyCharm2019.3/system/cythonExtensions/build/_pydevd_bundle/pydevd_cython.o: unable to initialize decompress status for section .debug_info
/home/kossak/.PyCharm2019.3/system/cythonExtensions/build/_pydevd_bundle/pydevd_cython.o: file not recognized: file format not recognized
collect2: error: ld returned 1 exit status
error: command 'gcc' failed with exit status 1

```

 

How to fix it?

I'm using:
PyCharm 2019.3.2 (Professional Edition)
Build #PY-193.6015.41, built on January 21, 2020
Runtime version: 11.0.5+10-b520.30 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 4.19.99-1-MANJARO
GC: ParNew, ConcurrentMarkSweep
Memory: 949M
Cores: 4
Registry:
Non-Bundled Plugins: BashSupport, IdeaVIM, mobi.hsz.idea.gitignore, org.nik.presentation-assistant, org.toml.lang

1 comment
Comment actions Permalink

Hello,

It seems to be similar to https://youtrack.jetbrains.com/issue/PY-34553, please vote for it and follow for updates.

See https://intellij-support.jetbrains.com/hc/en-us/articles/207241135-How-to-follow-YouTrack-issues-and-receive-notifications if you are not familiar with YouTrack.

There are several workarounds provided that worth trying. 

 

If none of them help, I suggest disabling cython extension by adding the following environment variable in your run/debug configuration:

PYDEVD_USE_CYTHON=NO

0

Please sign in to leave a comment.