Can't figure out how to get SQL editor to not indent JOIN lines

Answered

Even with the "indent JOIN" option unchecked under Editor->Code Style->SQL, the formatted code still looks like the following:

SELECT d.dep_id,
      p.per_id,
      count(*) as per_cnt,
      max(m.actual) as has_actual_template
from department d
     join manager m on d.dep_id = m.dep_id
     left join person p on m.per_id = p.per_id,

How can I make it look like the following:

SELECT d.dep_id,
      p.per_id,
      count(*) as per_cnt,
      max(m.actual) as has_actual_template
from department d
join manager m on d.dep_id = m.dep_id
left join person p on m.per_id = p.per_id,

 

1 comment
Comment actions Permalink

David Sharp,

Assuming you're working with PostgreSQL, could you try the following options?

0

Please sign in to leave a comment.