Unable to install plugin

Answered

Hi all,

I had installed PyCharm Community Edition 2020.1 x64 recently.

I was trying to install Intellibot plugin from the marketplace.

Clicking on 'Install' button turns itself to 'Restart IDE' in no time, and on clicking on 'Restart IDE' a pop-up appears showing 'Restart PyCharm to apply changes in plugins'. After clicking 'OK' button, PyCharm restarts.

After the restart I am unable to see the plugin under Installed.

If I look up for the same in marketplace, the same plugin is displayed with "Install" button as if it was not installed before.

I have tried Install plugin from disk option with a .jar file with the same results.

Thanks in advance.

5 comments
Comment actions Permalink

Does it happen with all plugins? For instance, how does it go with the IdeaVim plugin?
If it works, then you should contact the plugin vendor.

0
Comment actions Permalink

I get the following pop-up when I tried to install IdeaVim plugin.

0
Comment actions Permalink

So something is blocking PyCharm from accessing the file/directory.

If you use antivirus, try disabling it. If it appears that IDE is not blocked by any external process, reinstall PyCharm into an empty directory.

1
Comment actions Permalink

There was some access issue in that device.

So I have installed in another device and it is working fine.  Thanks for your help.

On a side note, is it possible to change the location where the plugin gets installed?

0

Please sign in to leave a comment.